summaryrefslogtreecommitdiff
path: root/user/libmateweather
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2023-04-11 13:59:21 -0700
committerZach van Rijn <me@zv.io>2023-04-11 13:59:21 -0700
commita5092455f503c3ecdfb1cdb788d509f36ad11a43 (patch)
tree3905f457b3003c834329638bb94e305d24a8b4c2 /user/libmateweather
parentc000ef3236e56fea510bba7463ac4b6be31a5c6e (diff)
downloadpackages-a5092455f503c3ecdfb1cdb788d509f36ad11a43.tar.gz
packages-a5092455f503c3ecdfb1cdb788d509f36ad11a43.tar.bz2
packages-a5092455f503c3ecdfb1cdb788d509f36ad11a43.tar.xz
packages-a5092455f503c3ecdfb1cdb788d509f36ad11a43.zip
user/libmateweather: add patch for { Kiev --> Kyiv } timezone. fixes #997.
Diffstat (limited to 'user/libmateweather')
-rw-r--r--user/libmateweather/APKBUILD9
-rw-r--r--user/libmateweather/fix-timezone.patch33
2 files changed, 39 insertions, 3 deletions
diff --git a/user/libmateweather/APKBUILD b/user/libmateweather/APKBUILD
index c80f82755..633801d58 100644
--- a/user/libmateweather/APKBUILD
+++ b/user/libmateweather/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Síle Ekaterin Liszka <sheila@vulpine.house>
pkgname=libmateweather
pkgver=1.26.0
-pkgrel=0
+pkgrel=1
pkgdesc="Weather library for the MATE desktop environment"
url="https://mate-desktop.org"
arch="all"
@@ -10,7 +10,9 @@ license="LGPL-2.1+ AND GPL-2.0+"
depends=""
makedepends="gtk+3.0-dev intltool libsoup-dev libxml2-dev libxml2-utils"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-source="https://pub.mate-desktop.org/releases/${pkgver%.*}/libmateweather-$pkgver.tar.xz"
+source="https://pub.mate-desktop.org/releases/${pkgver%.*}/libmateweather-$pkgver.tar.xz
+ fix-timezone.patch
+ "
build() {
./configure \
@@ -33,4 +35,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="e786071d8c9393abc6d8f0733bd213305ace50698066ba7913ac254d8944e6db94296de5ecf91c0d5a8babd38f0cc35cb3bcee046f1eb0339ec5429a66d062d1 libmateweather-1.26.0.tar.xz"
+sha512sums="e786071d8c9393abc6d8f0733bd213305ace50698066ba7913ac254d8944e6db94296de5ecf91c0d5a8babd38f0cc35cb3bcee046f1eb0339ec5429a66d062d1 libmateweather-1.26.0.tar.xz
+b4ab9363dc8b6fb84cbbc968a2557cd6b9ff96846f4c9aef565f27aa1383d14fdd51c7dc3a3177934e347490fa63f6e1724da399432ba6d68d26ffebc09f34cd fix-timezone.patch"
diff --git a/user/libmateweather/fix-timezone.patch b/user/libmateweather/fix-timezone.patch
new file mode 100644
index 000000000..5b6a7f743
--- /dev/null
+++ b/user/libmateweather/fix-timezone.patch
@@ -0,0 +1,33 @@
+diff --git a/data/Locations.xml.in b/data/Locations.xml.in
+index de1f5b3..2d8778c 100644
+--- a/data/Locations.xml.in
++++ b/data/Locations.xml.in
+@@ -20618,13 +20618,13 @@
+ <iso-code>UA</iso-code>
+ <fips-code>UP</fips-code>
+ <timezones>
+- <timezone id="Europe/Kiev">
++ <timezone id="Europe/Kyiv">
+ <obsoletes>Europe/Simferopol</obsoletes>
+ <obsoletes>Europe/Uzhgorod</obsoletes>
+ <obsoletes>Europe/Zaporozhye</obsoletes>
+ </timezone>
+ </timezones>
+- <tz-hint>Europe/Kiev</tz-hint>
++ <tz-hint>Europe/Kyiv</tz-hint>
+ <city>
+ <!-- A city in Ukraine -->
+ <name>Boryspil'</name>
+@@ -20697,10 +20697,10 @@
+ </city>
+ <city>
+ <!-- The capital of Ukraine.
+- "Kiev" is the traditional English name.
++ "Kyiv" is the traditional English name.
+ The local name in Ukrainian is "Kyyiv".
+ -->
+- <name>Kiev</name>
++ <name>Kyiv</name>
+ <coordinates>50.433333 30.516667</coordinates>
+ <location>
+ <name>Kyiv</name>