summaryrefslogtreecommitdiff
path: root/user/libmaxminddb
diff options
context:
space:
mode:
authorAlyx Wolcott <alyx@malkier.net>2020-02-22 19:39:34 -0600
committerAlyx Wolcott <alyx@malkier.net>2020-02-22 19:39:34 -0600
commitd14e248d2b12a7b2299e9103d2d1fd06ad925469 (patch)
tree33c6c23560ffc60169d7b6a70808d6db746d0b5a /user/libmaxminddb
parenta0cd65328e2226e261b58e516c48a700c2aafb5f (diff)
downloadpackages-d14e248d2b12a7b2299e9103d2d1fd06ad925469.tar.gz
packages-d14e248d2b12a7b2299e9103d2d1fd06ad925469.tar.bz2
packages-d14e248d2b12a7b2299e9103d2d1fd06ad925469.tar.xz
packages-d14e248d2b12a7b2299e9103d2d1fd06ad925469.zip
New packages: user/libgeoip, user/libmaxminddb, user/lua-yaml, user/yaml-cpp
Diffstat (limited to 'user/libmaxminddb')
-rw-r--r--user/libmaxminddb/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/user/libmaxminddb/APKBUILD b/user/libmaxminddb/APKBUILD
new file mode 100644
index 000000000..b7724ffdf
--- /dev/null
+++ b/user/libmaxminddb/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Alyx Wolcott <alyx@leuhta.com>
+# Maintainer: Alyx Wolcott <alyx@leuhta.com>
+pkgname=libmaxminddb
+pkgver=1.4.2
+pkgrel=0
+pkgdesc="Library for the MaxMind DB file format"
+url="http://maxmind.github.io/libmaxminddb/"
+arch="all"
+license="Apache-2.0"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://github.com/maxmind/libmaxminddb/releases/download/$pkgver/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="bc18d2f19a74639888a466483afde1bccfc3a83787011a6f38808b76e5a513c9912ff369ccbf584091d4def657e0574b16b35dc69ab12ae4c439aaaf3669c4c1 libmaxminddb-1.4.2.tar.gz"