summaryrefslogtreecommitdiff
path: root/user/libmspub
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2018-08-09 23:33:31 -0400
committerMax Rees <maxcrees@me.com>2018-08-09 23:33:31 -0400
commitff07c88493d997f1908c39849125e7f06526d85b (patch)
tree49912738e9346ed224ac563dac2c4b5e670ce90e /user/libmspub
parent0b2c4a78b9b601af688eba4648a8bff5e02d52fb (diff)
downloadpackages-ff07c88493d997f1908c39849125e7f06526d85b.tar.gz
packages-ff07c88493d997f1908c39849125e7f06526d85b.tar.bz2
packages-ff07c88493d997f1908c39849125e7f06526d85b.tar.xz
packages-ff07c88493d997f1908c39849125e7f06526d85b.zip
user/libmspub: pull in, fix license, mark no tests
Diffstat (limited to 'user/libmspub')
-rw-r--r--user/libmspub/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/user/libmspub/APKBUILD b/user/libmspub/APKBUILD
new file mode 100644
index 000000000..9b2de9baf
--- /dev/null
+++ b/user/libmspub/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Timo Teräs <timo.teras@iki.fi>
+# Maintainer: Max Rees <maxcrees@me.com>
+pkgname=libmspub
+pkgver=0.1.4
+pkgrel=0
+pkgdesc="Import filter and tools for Microsoft Publisher files"
+url="https://wiki.documentfoundation.org/DLP/Libraries/libmspub"
+arch="all"
+options="!check" # No test suite.
+license="MPL-2.0 AND (MPL-1.1 OR GPL-2.0+ OR LGPL-2.0+)"
+depends_dev="boost-dev librevenge-dev"
+makedepends="$depends_dev icu-dev doxygen"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-tools"
+source="http://dev-www.libreoffice.org/src/$pkgname/$pkgname-$pkgver.tar.xz"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+tools() {
+ mkdir -p "$subpkgdir"/usr
+ mv "$pkgdir"/usr/bin "$subpkgdir"/usr
+}
+
+sha512sums="7275f890645961b3fd56df4584788962e8c064fe3f99f5834c6ba6177ce76d00d544fbe9a25b7ab2f4180d2f3a90c609fe0bb68d61ea24e95b086190390fff31 libmspub-0.1.4.tar.xz"