summaryrefslogtreecommitdiff
path: root/user/libnftnl/APKBUILD
diff options
context:
space:
mode:
authormultiplexd <multi@in-addr.xyz>2019-01-08 19:46:31 +0000
committermultiplexd <multi@in-addr.xyz>2019-01-11 21:10:10 +0000
commitb74b52b3497bd84c18867d4259c48012ab375014 (patch)
tree113dc24e928a3b61c0e8ff992dc3cb11a7b1687b /user/libnftnl/APKBUILD
parentb8a4be9e71e9a8768cfa344b64bae186690a5fb1 (diff)
downloadpackages-b74b52b3497bd84c18867d4259c48012ab375014.tar.gz
packages-b74b52b3497bd84c18867d4259c48012ab375014.tar.bz2
packages-b74b52b3497bd84c18867d4259c48012ab375014.tar.xz
packages-b74b52b3497bd84c18867d4259c48012ab375014.zip
user/libnftnl: new package
Diffstat (limited to 'user/libnftnl/APKBUILD')
-rw-r--r--user/libnftnl/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/user/libnftnl/APKBUILD b/user/libnftnl/APKBUILD
new file mode 100644
index 000000000..432f60b07
--- /dev/null
+++ b/user/libnftnl/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Maintainer: multiplexd <multi@in-addr.xyz>
+pkgname=libnftnl
+pkgver=1.1.2
+pkgrel=0
+pkgdesc="Netfilter library providing interface to the nf_tables subsystem"
+url="https://netfilter.org/projects/libnftnl"
+arch="all"
+license="GPL-2.0+"
+makedepends="libmnl-dev"
+subpackages="$pkgname-dev"
+source="https://netfilter.org/projects/libnftnl/files/$pkgname-$pkgver.tar.bz2"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"/tests
+ make check # builds test binaries
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="808e0efd2ff32a65cca1e6113cc29aece1335364b94ad87438d19b0887d0bd34de11942fa411e4105ef153f2cce862ded17ebc441c413b839ac506471e530569 libnftnl-1.1.2.tar.bz2"