summaryrefslogtreecommitdiff
path: root/user/libotr
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2022-04-22 07:02:05 +0000
committerZach van Rijn <me@zv.io>2022-10-21 18:33:58 -0500
commit4bfd77173b70a21ef656d480c613d6e2481b7388 (patch)
tree78f70ced942ba044e6a5c823792372b7bb09e106 /user/libotr
parente70c05c5cea55e5190ca387125c0ce41d1b03042 (diff)
downloadpackages-4bfd77173b70a21ef656d480c613d6e2481b7388.tar.gz
packages-4bfd77173b70a21ef656d480c613d6e2481b7388.tar.bz2
packages-4bfd77173b70a21ef656d480c613d6e2481b7388.tar.xz
packages-4bfd77173b70a21ef656d480c613d6e2481b7388.zip
user/libotr: add missing include in test. fixes #553.
Diffstat (limited to 'user/libotr')
-rw-r--r--user/libotr/APKBUILD6
-rw-r--r--user/libotr/fix-client.patch11
2 files changed, 15 insertions, 2 deletions
diff --git a/user/libotr/APKBUILD b/user/libotr/APKBUILD
index 513c9f47a..aa9f28059 100644
--- a/user/libotr/APKBUILD
+++ b/user/libotr/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=libotr
pkgver=4.1.1
-pkgrel=0
+pkgrel=1
pkgdesc="Messaging library for secure, encrypted communications"
url="https://otr.cypherpunks.ca/"
arch="all"
@@ -13,6 +13,7 @@ makedepends="$depends_dev"
subpackages="$pkgname-dev $pkgname-doc"
source="https://otr.cypherpunks.ca/libotr-$pkgver.tar.gz
fix-test.patch
+ fix-client.patch
"
prepare() {
@@ -40,4 +41,5 @@ package() {
}
sha512sums="c957206235b9f627542f23a645c822ea1b318d83fa655f41ed8d9a3c0dddf30b88f0ca82060026af155e48ecb13969dc9270831f20304669794151f666ae5cb0 libotr-4.1.1.tar.gz
-dcd1e55619b2ef51f14257cddcceb5f1b850da42c2acb7547713256a377df60d30591d06522fe6982db8c261687f1f18640a1ffaaf1c701d9356bd97dab1d8c8 fix-test.patch"
+dcd1e55619b2ef51f14257cddcceb5f1b850da42c2acb7547713256a377df60d30591d06522fe6982db8c261687f1f18640a1ffaaf1c701d9356bd97dab1d8c8 fix-test.patch
+7f9521c37a91ac396908ce6e92acb962a5528055809b81754ff27c77c1dbc952bfce2d97c538ca30d6c7dab7a119394ca5367a572287c6cb03fa7ca7f6a9e854 fix-client.patch"
diff --git a/user/libotr/fix-client.patch b/user/libotr/fix-client.patch
new file mode 100644
index 000000000..97ad56ffe
--- /dev/null
+++ b/user/libotr/fix-client.patch
@@ -0,0 +1,11 @@
+diff -ur a/tests/regression/client/client.c b/tests/regression/client/client.c
+--- a/tests/regression/client/client.c 2022-04-22 06:59:42.455423399 +0000
++++ b/tests/regression/client/client.c 2022-04-22 07:00:15.356315251 +0000
+@@ -26,6 +26,7 @@
+ #include <stdlib.h>
+ #include <syscall.h>
+ #include <sys/epoll.h>
++#include <sys/socket.h>
+ #include <sys/types.h>
+ #include <sys/un.h>
+ #include <unistd.h>