summaryrefslogtreecommitdiff
path: root/user/libpsl
diff options
context:
space:
mode:
authorKiyoshi Aman <kiyoshi.aman+apkfission@gmail.com>2018-09-03 12:01:45 -0500
committerKiyoshi Aman <kiyoshi.aman+apkfission@gmail.com>2018-09-03 12:01:45 -0500
commit84f5c390443a4dd107c408bef0813c68d7cccd8f (patch)
tree60822fa005e1b633522e678f0be348267f95d802 /user/libpsl
parentdf5fcf4c4bcbda3da6fc728c2456391541bbf5a2 (diff)
downloadpackages-84f5c390443a4dd107c408bef0813c68d7cccd8f.tar.gz
packages-84f5c390443a4dd107c408bef0813c68d7cccd8f.tar.bz2
packages-84f5c390443a4dd107c408bef0813c68d7cccd8f.tar.xz
packages-84f5c390443a4dd107c408bef0813c68d7cccd8f.zip
user/libpsl: new package
Diffstat (limited to 'user/libpsl')
-rw-r--r--user/libpsl/APKBUILD38
-rw-r--r--user/libpsl/use-python3.patch9
2 files changed, 47 insertions, 0 deletions
diff --git a/user/libpsl/APKBUILD b/user/libpsl/APKBUILD
new file mode 100644
index 000000000..9f4e97f9e
--- /dev/null
+++ b/user/libpsl/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+pkgname=libpsl
+pkgver=0.20.2
+pkgrel=0
+pkgdesc="C library for examining the Public Suffix List"
+url="https://rockdaboot.github.io/libpsl"
+arch="all"
+license="MIT AND BSD-3-Clause"
+makedepends="python3 libidn2-dev libunistring-dev"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://github.com/rockdaboot/libpsl/releases/download/libpsl-$pkgver/libpsl-$pkgver.tar.gz
+ use-python3.patch"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="fa9f6f7f0447d9fe00f5dfca5262c56ff26217eea44d0f7fc1e5d982224c41874e753f0aa06dd9e5d7d03d4f04e3dacd4f36034cc8dd0fc6e2c28b49a23e62fe libpsl-0.20.2.tar.gz
+00c9c09bac334efcd7ae6240b740ac88453425cc380cc23b443a0579f4ccabf86eafdb90f5f05027cc55ee20f6c1d4388939792a55cd95705d5e6919d40b30e5 use-python3.patch"
diff --git a/user/libpsl/use-python3.patch b/user/libpsl/use-python3.patch
new file mode 100644
index 000000000..5f9cb8bf5
--- /dev/null
+++ b/user/libpsl/use-python3.patch
@@ -0,0 +1,9 @@
+diff -Nurd libpsl-0.20.2/src/psl-make-dafsa libpsl-0.20.2.new/src/psl-make-dafsa
+--- libpsl-0.20.2/src/psl-make-dafsa 2018-04-19 02:36:59.000000000 -0500
++++ libpsl-0.20.2.new/src/psl-make-dafsa 2018-09-03 11:29:35.036414479 -0500
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python3
+ # Copyright 2014 The Chromium Authors. All rights reserved.
+ # Use of this source code is governed by a BSD-style license that can be
+ # found in the LICENSE.chromium file.