summaryrefslogtreecommitdiff
path: root/user/libpthread-stubs
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-05 00:15:00 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-05 00:15:00 -0500
commit7647b000545d651114f517e434eb02313dbeb732 (patch)
tree2ef6b730343f299b1a5347082965717e4171414f /user/libpthread-stubs
parentd770c829b45a28a8a98813754ccdc2d981562eea (diff)
downloadpackages-7647b000545d651114f517e434eb02313dbeb732.tar.gz
packages-7647b000545d651114f517e434eb02313dbeb732.tar.bz2
packages-7647b000545d651114f517e434eb02313dbeb732.tar.xz
packages-7647b000545d651114f517e434eb02313dbeb732.zip
user/libpthread-stubs: stop looking at my corgi butt, xcb
Diffstat (limited to 'user/libpthread-stubs')
-rw-r--r--user/libpthread-stubs/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/user/libpthread-stubs/APKBUILD b/user/libpthread-stubs/APKBUILD
new file mode 100644
index 000000000..5c5301b08
--- /dev/null
+++ b/user/libpthread-stubs/APKBUILD
@@ -0,0 +1,38 @@
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=libpthread-stubs
+pkgver=0.3
+pkgrel=6
+pkgdesc="Pthread functions stubs for platforms missing them"
+url="https://cgit.freedesktop.org/xcb/pthread-stubs"
+arch="all"
+options="!dbg"
+license="X11"
+source="http://xcb.freedesktop.org/dist/$pkgname-$pkgver.tar.bz2"
+
+prepare() {
+ default_prepare
+
+ cd "$builddir"
+ update_config_sub
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make -j1 DESTDIR="$pkgdir" install
+}
+
+sha512sums="c7cf63fa82ce9e8c37c6dc3b8cc30f8883655f95683c4466c54b617b086dd26a43bfa36363e47dc5730af6d59ac70443d211eb01b07d276edd144030a3580b15 libpthread-stubs-0.3.tar.bz2"