summaryrefslogtreecommitdiff
path: root/user/libqxp
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2019-03-11 05:57:38 -0400
committerMax Rees <maxcrees@me.com>2019-03-11 23:36:53 -0400
commit73e51bf675c292c00724d49811454995b7e236b4 (patch)
tree259f1368597c7d0b3739a5a4d6ac41fbecbbe293 /user/libqxp
parent5661219952e9f760900f6c6021f452b650290aae (diff)
downloadpackages-73e51bf675c292c00724d49811454995b7e236b4.tar.gz
packages-73e51bf675c292c00724d49811454995b7e236b4.tar.bz2
packages-73e51bf675c292c00724d49811454995b7e236b4.tar.xz
packages-73e51bf675c292c00724d49811454995b7e236b4.zip
user/libqxp: bump to 0.0.2
Diffstat (limited to 'user/libqxp')
-rw-r--r--user/libqxp/APKBUILD15
1 files changed, 6 insertions, 9 deletions
diff --git a/user/libqxp/APKBUILD b/user/libqxp/APKBUILD
index 6476cc5f0..89f03aa6f 100644
--- a/user/libqxp/APKBUILD
+++ b/user/libqxp/APKBUILD
@@ -1,21 +1,19 @@
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=libqxp
-pkgver=0.0.1
-pkgrel=1
+pkgver=0.0.2
+pkgrel=0
pkgdesc="Import filter and tools for QuarkXPress documents"
url="https://wiki.documentfoundation.org/DLP/Libraries/libqxp"
arch="all"
license="MPL-2.0"
depends=""
-depends_dev="librevenge-dev"
-makedepends="$depends_dev icu-dev doxygen"
+makedepends="librevenge-dev icu-dev doxygen"
checkdepends="cppunit-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-tools"
source="https://dev-www.libreoffice.org/src/$pkgname/$pkgname-$pkgver.tar.xz"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -25,17 +23,16 @@ build() {
--infodir=/usr/share/info \
--localstatedir=/var \
make
- cd "$builddir/docs"
+
+ cd docs
make
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
@@ -44,4 +41,4 @@ tools() {
mv "$pkgdir"/usr/bin "$subpkgdir"/usr
}
-sha512sums="a03a9ada658a92f4d985cad91d467b3916334c74dc26c1e4de89e3929e0135ca0e9c7e7e18ce616ef56a67863ec19c2638494400785849017f9a4776df07c607 libqxp-0.0.1.tar.xz"
+sha512sums="409d3df82ac522b39bdd0ef4f0a781b906e246a8e6f502009c095eea90d672c482a7fc5c7f998d89952bc598c6f51357346ed6df490c25cb48e1318e27c50dab libqxp-0.0.2.tar.xz"