summaryrefslogtreecommitdiff
path: root/user/libseccomp
diff options
context:
space:
mode:
authorNathan <ndowens@artixlinux.org>2020-10-22 20:16:16 +0000
committerNathan <ndowens@artixlinux.org>2020-10-24 23:35:03 +0000
commit65f9d55cf95a0670a4755b2f18685d1f17d6faf5 (patch)
tree0e5a56eaefb0f355c018f6c67ea291a2a81fb38d /user/libseccomp
parent60c5b0f127e002057c3e057b59da6178808d59d4 (diff)
downloadpackages-65f9d55cf95a0670a4755b2f18685d1f17d6faf5.tar.gz
packages-65f9d55cf95a0670a4755b2f18685d1f17d6faf5.tar.bz2
packages-65f9d55cf95a0670a4755b2f18685d1f17d6faf5.tar.xz
packages-65f9d55cf95a0670a4755b2f18685d1f17d6faf5.zip
user/libseccomp: Add
Diffstat (limited to 'user/libseccomp')
-rw-r--r--user/libseccomp/APKBUILD46
-rw-r--r--user/libseccomp/remove-redefinition-prctl.patch10
2 files changed, 56 insertions, 0 deletions
diff --git a/user/libseccomp/APKBUILD b/user/libseccomp/APKBUILD
new file mode 100644
index 000000000..3a26c908a
--- /dev/null
+++ b/user/libseccomp/APKBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Nathan <ndowens@artixlinux.org>
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Contributor: Dan Williams <dan@ma.ssive.co>
+pkgname=libseccomp
+pkgver=2.5.0
+pkgrel=0
+pkgdesc="An interface to the Linux Kernel's syscall filtering mechanism"
+url="https://github.com/seccomp/libseccomp"
+arch="all"
+license="LGPL-2.1+"
+depends=""
+makedepends="linux-headers gperf"
+checkdepends="bash cmd:which"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://github.com/seccomp/libseccomp/releases/download/v$pkgver/libseccomp-$pkgver.tar.gz
+ remove-redefinition-prctl.patch
+ "
+
+# secfixes:
+# 2.4.0-r0:
+# - CVE-2019-9893
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --enable-static \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="00ef5aeb4db8dafb546ae680b2d6d9b6aeed008df805d0f28f9dd15c074ff6ea7a5e5131ab503825b8011c59aa23046baedd5849ca040aa73352f43ab2d602ae libseccomp-2.5.0.tar.gz
+f2c31dcafdc9a1ad78e32e76b75e1c1603071eaa3f979e1f2483b879a34ad07e0a4ef3642196a695415cdf81e1ed2bf325175872fb4e203ef9d0e668c287493f remove-redefinition-prctl.patch"
diff --git a/user/libseccomp/remove-redefinition-prctl.patch b/user/libseccomp/remove-redefinition-prctl.patch
new file mode 100644
index 000000000..2ea88fe05
--- /dev/null
+++ b/user/libseccomp/remove-redefinition-prctl.patch
@@ -0,0 +1,10 @@
+--- ./src/system.c.orig
++++ ./src/system.c
+@@ -21,7 +21,6 @@
+
+ #include <stdlib.h>
+ #include <errno.h>
+-#include <sys/prctl.h>
+
+ #include <seccomp.h>
+