summaryrefslogtreecommitdiff
path: root/user/libsigc++3/APKBUILD
diff options
context:
space:
mode:
authorSíle Ekaterin Liszka <sheila@vulpine.house>2022-06-12 05:34:01 +0000
committerZach van Rijn <me@zv.io>2022-10-21 18:34:02 -0500
commit4d028f2fda46d575ac0fda4d23244e60a0b42e2d (patch)
treee19176aee838fc97682c1bd1dbe9dc7ae030d045 /user/libsigc++3/APKBUILD
parentce25032293af10a591b4e85fb73f09e556b3ee4e (diff)
downloadpackages-4d028f2fda46d575ac0fda4d23244e60a0b42e2d.tar.gz
packages-4d028f2fda46d575ac0fda4d23244e60a0b42e2d.tar.bz2
packages-4d028f2fda46d575ac0fda4d23244e60a0b42e2d.tar.xz
packages-4d028f2fda46d575ac0fda4d23244e60a0b42e2d.zip
user/libsigc++3: new package
Diffstat (limited to 'user/libsigc++3/APKBUILD')
-rw-r--r--user/libsigc++3/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/user/libsigc++3/APKBUILD b/user/libsigc++3/APKBUILD
new file mode 100644
index 000000000..6273ddca3
--- /dev/null
+++ b/user/libsigc++3/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Síle Ekaterin Liszka <sheila@vulpine.house>
+# Maintainer: Síle Ekaterin Liszka <sheila@vulpine.house>
+pkgname=libsigc++3
+_pkgreal=${pkgname%3}
+pkgver=3.2.0
+pkgrel=0
+pkgdesc="Library for type-safe callbacks in C++"
+url="https://libsigcplusplus.github.io/libsigcplusplus/download.html"
+arch="all"
+license="LGPL-2.1+ AND LGPL-3.0+"
+depends=""
+makedepends="boost-dev doxygen graphviz meson ninja cmd:xsltproc"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://download.gnome.org/sources/$_pkgreal/${pkgver%.*}/$_pkgreal-$pkgver.tar.xz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+ meson \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --buildtype=release \
+ --wrap-mode=nofallback \
+ -Dbuild-examples=false \
+ -Dbuild-documentation=true \
+ . output
+ ninja -C output
+}
+
+check() {
+ ninja -C output test
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C output install
+}
+
+sha512sums="91315cecc79a1ad6ea165b66a13a5afd4e5bc101842f9d4c58811ea78536c07fc8821c51aa5110a032ed71c09f85790b3a02f2ad7fe8cc3aed6e03b2bafcd70c libsigc++-3.2.0.tar.xz"