summaryrefslogtreecommitdiff
path: root/user/libstatgrab
diff options
context:
space:
mode:
authorKiyoshi Aman <kiyoshi.aman+adelie@gmail.com>2019-07-20 17:45:51 -0500
committerKiyoshi Aman <kiyoshi.aman+adelie@gmail.com>2019-07-20 17:45:51 -0500
commitf702bcc799dd029474679f0e18a5e6b0523e7c2a (patch)
tree93a9bf222cfbb3f4080289d42c10168ac2e15aea /user/libstatgrab
parentd3eb7058d8f66a7fa94c262314df4c95a76a36fc (diff)
downloadpackages-f702bcc799dd029474679f0e18a5e6b0523e7c2a.tar.gz
packages-f702bcc799dd029474679f0e18a5e6b0523e7c2a.tar.bz2
packages-f702bcc799dd029474679f0e18a5e6b0523e7c2a.tar.xz
packages-f702bcc799dd029474679f0e18a5e6b0523e7c2a.zip
user/libstatgrab: upgrade to 0.92
Diffstat (limited to 'user/libstatgrab')
-rw-r--r--user/libstatgrab/APKBUILD17
-rw-r--r--user/libstatgrab/fix-configure.patch14
-rw-r--r--user/libstatgrab/nongnu.patch12
3 files changed, 4 insertions, 39 deletions
diff --git a/user/libstatgrab/APKBUILD b/user/libstatgrab/APKBUILD
index a86f93f52..a1a24c35b 100644
--- a/user/libstatgrab/APKBUILD
+++ b/user/libstatgrab/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
pkgname=libstatgrab
-pkgver=0.91
+pkgver=0.92
pkgrel=0
pkgdesc="Library for cross-platform access to system statistics."
url="https://www.i-scream.org/libstatgrab"
@@ -12,15 +12,10 @@ depends_dev="ncurses-dev"
checkdepends="perl"
makedepends="autoconf automake libtool utmps-dev $depends_dev"
subpackages="$pkgname-dev $pkgname-doc"
-source="https://ftp.i-scream.org/pub/i-scream/$pkgname/$pkgname-$pkgver.tar.gz
- fix-configure.patch
- nongnu.patch"
+source="https://ftp.i-scream.org/pub/i-scream/$pkgname/$pkgname-$pkgver.tar.gz"
build() {
cd "$builddir"
- aclocal
- libtoolize -if --recursive
- autoreconf -if
LIBS="-lutmps -lskarnet -ltinfo" ./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -28,9 +23,7 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--localstatedir=/var \
- --enable-maintainer-mode \
- --disable-man-build \
- ac_cv_header_sys_sysinfo_h=no
+ --disable-man-build
make
}
@@ -44,6 +37,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="f360f2e1b185bf9603b1d9c50649b0050e9502128ff81a9f4de88457e2f5203deafe7fd7ac13ebc4cc56e6ecd1bdf8aacae64987bdf36af0c9929e30626915f6 libstatgrab-0.91.tar.gz
-96661b2d4c4c54fde9b2cb57e3a9d84e950aae130017a7496a60b630ec7c30d8c6ee270d8f2976f8179f4926073a39d92116e4abce2f4c742d4d5e08bc031f4e fix-configure.patch
-9c42c860c0939b60fcba26d86d65c8e5f1e64e5e6d0646eb7d6ab72b1926f655f0ae8212823cf6e0e1afb1b9098a4d02503847304ce5e20d0540329c10d23d7f nongnu.patch"
+sha512sums="a99c6be56d930779d0d8f6f81e64e2f31e19423009c39e925b39116a42aa2c6037651992ac2168c43a5c6ecadf3e4a58486ab6148cf96118c429b04fdcf65192 libstatgrab-0.92.tar.gz"
diff --git a/user/libstatgrab/fix-configure.patch b/user/libstatgrab/fix-configure.patch
deleted file mode 100644
index 4ae6fdbc3..000000000
--- a/user/libstatgrab/fix-configure.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -Nurd libstatgrab-0.91/configure.ac libstatgrab-0.91.new/configure.ac
---- libstatgrab-0.91/configure.ac 2014-07-11 19:12:06.000000000 +0000
-+++ libstatgrab-0.91.new/configure.ac 2017-10-10 18:17:14.094496592 +0000
-@@ -609,8 +609,8 @@
- [openbsd*], [
- AC_DEFINE(OPENBSD, , [Building on OpenBSD])
- ],
-- [linux-gnu*], [
-- AC_DEFINE(LINUX, , [Building on GNU/Linux])
-+ [linux*], [
-+ AC_DEFINE(LINUX, , [Building on Linux])
- AM_CONDITIONAL(SETUIDBINS, true)
- BIN_OWNER="root"
- BIN_PERM="4755"
diff --git a/user/libstatgrab/nongnu.patch b/user/libstatgrab/nongnu.patch
deleted file mode 100644
index 3e5e163f7..000000000
--- a/user/libstatgrab/nongnu.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Nurd libstatgrab-0.91/src/libstatgrab/os_info.c libstatgrab-0.91.new/src/libstatgrab/os_info.c
---- libstatgrab-0.91/src/libstatgrab/os_info.c 2014-06-19 11:41:10.000000000 +0000
-+++ libstatgrab-0.91.new/src/libstatgrab/os_info.c 2017-10-10 18:42:04.844471568 +0000
-@@ -472,7 +472,7 @@
- host_info_buf->bitwidth = 64;
- }
- else {
-- host_info_buf->bitwidth = sysconf(_SC_LONG_BIT); // well, maybe 64-bit disabled 128-bit system o.O
-+ host_info_buf->bitwidth = sizeof(long int) * 8; // well, maybe 64-bit disabled 128-bit system o.O
- }
- host_info_buf->host_state = sg_unknown_configuration;
- # endif