summaryrefslogtreecommitdiff
path: root/user/libuninameslist
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-01-15 19:17:20 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-01-15 19:17:20 +0000
commit6e7935e7f82732c5ae7b1d2dcd539eb4788c958c (patch)
tree50617738d53e87c9f129ecad7bbd6edaa26e62eb /user/libuninameslist
parent52a2fc672b71a5c4b5a7d8338e504a10c695b293 (diff)
downloadpackages-6e7935e7f82732c5ae7b1d2dcd539eb4788c958c.tar.gz
packages-6e7935e7f82732c5ae7b1d2dcd539eb4788c958c.tar.bz2
packages-6e7935e7f82732c5ae7b1d2dcd539eb4788c958c.tar.xz
packages-6e7935e7f82732c5ae7b1d2dcd539eb4788c958c.zip
user/libuninameslist: new package
Diffstat (limited to 'user/libuninameslist')
-rw-r--r--user/libuninameslist/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/user/libuninameslist/APKBUILD b/user/libuninameslist/APKBUILD
new file mode 100644
index 000000000..1deffebdc
--- /dev/null
+++ b/user/libuninameslist/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=libuninameslist
+pkgver=20180701
+pkgrel=0
+pkgdesc="Library of Unicode names and annotation data"
+url=" "
+arch="all"
+license="BSD-3-Clause"
+depends=""
+makedepends="python3-dev"
+subpackages="$pkgname-dev $pkgname-doc py3-uninameslist:py3:noarch"
+source="https://github.com/fontforge/libuninameslist/releases/download/$pkgver/libuninameslist-dist-$pkgver.tar.gz"
+
+build() {
+ cd "$builddir"
+ PYTHON=python3 ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+py3() {
+ pkgdesc="$pkgdesc (Python 3 bindings)"
+ depends="python3"
+ cd "$builddir"/py
+ python3 setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="839f8a0c3a81b4b19ce6ddfa08fa9ca99fdcefe2ef2b2c5515b276fab594fb5325ae9c83b58e19c559c033e880bd098687022c8ec3da028b143f4a72c471f19c libuninameslist-dist-20180701.tar.gz"