summaryrefslogtreecommitdiff
path: root/user/libva
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-18 21:36:56 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-18 21:36:56 -0500
commitf931e2d891b8a77694c37b4be525796b20932db8 (patch)
treea2386aa522841c692f672f347922a4188140f189 /user/libva
parentb4155c5ef8c89d7032c40b2db485f4d034c2c4e0 (diff)
downloadpackages-f931e2d891b8a77694c37b4be525796b20932db8.tar.gz
packages-f931e2d891b8a77694c37b4be525796b20932db8.tar.bz2
packages-f931e2d891b8a77694c37b4be525796b20932db8.tar.xz
packages-f931e2d891b8a77694c37b4be525796b20932db8.zip
user/libva: pull in, bump to 2.2.0, fix up
Diffstat (limited to 'user/libva')
-rw-r--r--user/libva/APKBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/user/libva/APKBUILD b/user/libva/APKBUILD
new file mode 100644
index 000000000..36540477b
--- /dev/null
+++ b/user/libva/APKBUILD
@@ -0,0 +1,48 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libva
+pkgver=2.2.0
+pkgrel=0
+pkgdesc="Video Acceleration (VA) API for Linux"
+url="https://github.com/intel/libva"
+arch="all"
+options="!check" # No test suite.
+license="MIT"
+depends=""
+depends_dev="mesa-dev"
+makedepends="$depends_dev autoconf automake libtool"
+subpackages="$pkgname-dev"
+source="https://github.com/intel/${pkgname}/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.bz2"
+
+prepare() {
+ cd "$builddir"
+ default_prepare
+ # we need to regen the configure script which will unconditionally
+ # depend on wayland scanner otherwise
+ libtoolize --force && aclocal -I m4 && autoconf \
+ && automake --add-missing
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --enable-x11 \
+ --disable-wayland \
+ --disable-static \
+ --enable-shared
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="21e79b32cd846f3786635f470763c2046b302fdd3574eb70ac67c40140168ec76a33e2bbcdd2408859b38b9774fa15c89429e128ef381092505b4f39b1b1331a libva-2.2.0.tar.bz2"