summaryrefslogtreecommitdiff
path: root/user/libwacom/musl-test.patch
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-25 05:48:11 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-25 05:48:11 -0600
commit855bac716d6e87b113c4ea91efed989712917d97 (patch)
treeb2ab3cf4aa285baec2d54255a9e7aebdcc88ca42 /user/libwacom/musl-test.patch
parent3b4082481339e7e4254011eb5088a2f6cdb4bace (diff)
downloadpackages-855bac716d6e87b113c4ea91efed989712917d97.tar.gz
packages-855bac716d6e87b113c4ea91efed989712917d97.tar.bz2
packages-855bac716d6e87b113c4ea91efed989712917d97.tar.xz
packages-855bac716d6e87b113c4ea91efed989712917d97.zip
user/libwacom: bump to 1.2
Diffstat (limited to 'user/libwacom/musl-test.patch')
-rw-r--r--user/libwacom/musl-test.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/user/libwacom/musl-test.patch b/user/libwacom/musl-test.patch
new file mode 100644
index 000000000..74625f02b
--- /dev/null
+++ b/user/libwacom/musl-test.patch
@@ -0,0 +1,22 @@
+--- libwacom-1.2/meson.build.old 2019-12-22 21:45:06.000000000 +0000
++++ libwacom-1.2/meson.build 2019-12-25 11:43:51.004107631 +0000
+@@ -555,7 +555,7 @@
+ # because of the tricks we use in calling the function and exposing
+ # it to begin with, LTO gets confused and this fails to link.
+ # Let's just disable it here.
+- if not get_option('b_lto')
++ if not get_option('b_lto') and get_option('test_deprecated')
+ test_deprecated = executable('test-deprecated',
+ 'test/test-deprecated.c',
+ dependencies: [dep_libwacom, dep_dl],
+--- libwacom-1.2/meson_options.txt.old 2019-11-07 02:25:47.000000000 +0000
++++ libwacom-1.2/meson_options.txt 2019-12-25 11:45:11.585452086 +0000
+@@ -10,4 +10,8 @@
+ type: 'boolean',
+ value: true,
+ description: 'Build the tests [default=true]')
++option('test_deprecated',
++ type: 'boolean',
++ value: true,
++ description: 'Test the deprecated ABI (fails on musl) [default=true]')
+