summaryrefslogtreecommitdiff
path: root/user/libxcursor
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-05 04:16:46 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-05 04:16:46 -0500
commita84b69a6dad936d504dd0f418abb6909ae7958ea (patch)
treed8c5835428cc7cd3695cec807b38a1436e76af9d /user/libxcursor
parent0024a30a8b56a36ece2f2716e5ee2136849a2dcc (diff)
downloadpackages-a84b69a6dad936d504dd0f418abb6909ae7958ea.tar.gz
packages-a84b69a6dad936d504dd0f418abb6909ae7958ea.tar.bz2
packages-a84b69a6dad936d504dd0f418abb6909ae7958ea.tar.xz
packages-a84b69a6dad936d504dd0f418abb6909ae7958ea.zip
user/libxcursor: pull in, take, fix
Diffstat (limited to 'user/libxcursor')
-rw-r--r--user/libxcursor/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/user/libxcursor/APKBUILD b/user/libxcursor/APKBUILD
new file mode 100644
index 000000000..857cc5114
--- /dev/null
+++ b/user/libxcursor/APKBUILD
@@ -0,0 +1,39 @@
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=libxcursor
+pkgver=1.1.15
+pkgrel=1
+pkgdesc="X cursor management library"
+url="https://www.X.Org/"
+arch="all"
+license="MIT"
+subpackages="$pkgname-dev $pkgname-doc"
+depends=
+makedepends="libx11-dev libxfixes-dev libxrender-dev util-macros xorgproto-dev"
+source="https://www.X.Org/releases/individual/lib/libXcursor-$pkgver.tar.bz2"
+builddir="$srcdir"/libXcursor-$pkgver
+
+# secfixes:
+# 1.1.15-r0:
+# - CVE-2017-16612
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="53ad0fa2afd7b4cf1108b560e44ea71abdf5c55a18df243d7123942513589c927f5c105395f790d8769959e0129db54264e6aac7efd51a5f1aec270379b1f2f5 libXcursor-1.1.15.tar.bz2"