summaryrefslogtreecommitdiff
path: root/user/libxkbcommon
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-23 22:58:19 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-23 22:58:19 -0600
commit54bf4e1a2c9aefec3311e33e359557016a40f141 (patch)
tree5ccaeabee5f40334949ea30faea5e933938296e0 /user/libxkbcommon
parentf869544c5f6e6144381784973b2fe9343cea044d (diff)
downloadpackages-54bf4e1a2c9aefec3311e33e359557016a40f141.tar.gz
packages-54bf4e1a2c9aefec3311e33e359557016a40f141.tar.bz2
packages-54bf4e1a2c9aefec3311e33e359557016a40f141.tar.xz
packages-54bf4e1a2c9aefec3311e33e359557016a40f141.zip
user/libxkbcommon: bump to 0.9.1
* Uses Meson build system now * Forces documentation so we get a -doc package now * Disable Wayland support (it was never enabled, but explicitly disable it since it is default-on now)
Diffstat (limited to 'user/libxkbcommon')
-rw-r--r--user/libxkbcommon/APKBUILD31
1 files changed, 13 insertions, 18 deletions
diff --git a/user/libxkbcommon/APKBUILD b/user/libxkbcommon/APKBUILD
index 6dc619982..6825a2701 100644
--- a/user/libxkbcommon/APKBUILD
+++ b/user/libxkbcommon/APKBUILD
@@ -1,38 +1,33 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=libxkbcommon
-pkgver=0.8.4
+pkgver=0.9.1
pkgrel=0
pkgdesc="Keyboard handling library"
url="https://www.xkbcommon.org/"
arch="all"
license="MIT AND X11"
-makedepends="bison flex libxcb-dev util-macros xorgproto-dev"
+depends="xkeyboard-config"
checkdepends="bash"
-subpackages="$pkgname-dev"
+makedepends="bison doxygen flex libxcb-dev meson ninja util-macros
+ xorgproto-dev"
+subpackages="$pkgname-dev $pkgname-doc"
source="https://www.xkbcommon.org/download/libxkbcommon-$pkgver.tar.xz"
build() {
- cd "$builddir"
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --localstatedir=/var
- make
+ meson \
+ -Dprefix=/usr \
+ -Denable-wayland=false \
+ build
+ ninja -C build
}
check() {
- cd "$builddir"
- make check
+ ninja -C build test
}
package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" ninja -C build install
}
-sha512sums="dbd441d0d7d5ba4fb352d64d150d163d4cdcf8340059457c291dc1fc69d1606ff6589732cb41a7fcfe106af0192977b243d7d68c4d95b90ece7abb620df360e3 libxkbcommon-0.8.4.tar.xz"
+sha512sums="8d4551a06e7dd4936633f544409401dc33f8f1900adb5daa6403615c71f321d17212db739f89a5b3e393d729b3f33167691404849a25d5526b403fd9ec3e8878 libxkbcommon-0.9.1.tar.xz"