summaryrefslogtreecommitdiff
path: root/user/lighttpd/APKBUILD
diff options
context:
space:
mode:
authorGlenn Strauss <gstrauss@gluelogic.com>2023-11-02 14:03:53 -0400
committerGlenn Strauss <gstrauss@gluelogic.com>2023-11-03 14:36:56 -0400
commite08c32a45393aa31f660e138415a5bbe7603ee8d (patch)
tree5cd36bdecc5aae71809912ee71b8fe5296eccc17 /user/lighttpd/APKBUILD
parent7f11dddb9a842e04989855b18549e12783c287f4 (diff)
downloadpackages-e08c32a45393aa31f660e138415a5bbe7603ee8d.tar.gz
packages-e08c32a45393aa31f660e138415a5bbe7603ee8d.tar.bz2
packages-e08c32a45393aa31f660e138415a5bbe7603ee8d.tar.xz
packages-e08c32a45393aa31f660e138415a5bbe7603ee8d.zip
user/lighttpd: Bump to 1.4.73, modernize config
Diffstat (limited to 'user/lighttpd/APKBUILD')
-rw-r--r--user/lighttpd/APKBUILD73
1 files changed, 42 insertions, 31 deletions
diff --git a/user/lighttpd/APKBUILD b/user/lighttpd/APKBUILD
index b501a5f18..b79d8800d 100644
--- a/user/lighttpd/APKBUILD
+++ b/user/lighttpd/APKBUILD
@@ -1,21 +1,37 @@
# Contributor: Valery Kartel <valery.kartel@gmail.com>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=lighttpd
-pkgver=1.4.55
+pkgver=1.4.73
pkgrel=0
pkgdesc="A secure, fast, compliant and very flexible web-server"
-url="http://www.lighttpd.net/"
+url="https://www.lighttpd.net"
pkgusers="lighttpd"
pkggroups="lighttpd"
arch="all"
license="BSD-3-Clause"
depends=""
-makedepends="attr-dev bzip2-dev flex gamin-dev libev-dev libxml2-dev
- openldap-dev openssl-dev pcre-dev sqlite-dev zlib-dev"
-subpackages="$pkgname-doc $pkgname-dbg $pkgname-mod_auth $pkgname-openrc
- $pkgname-mod_webdav"
+makedepends="
+ attr-dev
+ flex
+ libxml2-dev
+ lua5.3-dev
+ meson
+ openldap-dev
+ openssl-dev
+ pcre2-dev
+ sqlite-dev
+ zlib-dev
+ zstd-dev
+ "
+checkdepends="perl"
+subpackages="
+ $pkgname-doc
+ $pkgname-openrc
+ $pkgname-mod_auth
+ $pkgname-mod_webdav
+ "
install="$pkgname.pre-install $pkgname.pre-upgrade"
-source="http://download.lighttpd.net/lighttpd/releases-1.4.x/$pkgname-$pkgver.tar.xz
+source="https://download.lighttpd.net/lighttpd/releases-1.4.x/lighttpd-$pkgver.tar.xz
$pkgname.initd
$pkgname.confd
$pkgname.logrotate
@@ -27,32 +43,25 @@ source="http://download.lighttpd.net/lighttpd/releases-1.4.x/$pkgname-$pkgver.ta
"
build() {
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --disable-dependency-tracking \
- --enable-lfs \
- --libdir=/usr/lib/lighttpd \
- --without-mysql \
- --with-attr \
- --with-fam \
- --with-webdav-props \
- --with-webdav-locks \
- --without-gdbm \
- --with-bzip2 \
- --with-ldap \
- --with-openssl \
- --with-libev
- make
+ meson \
+ -Dwith_ldap=enabled \
+ -Dwith_lua=true \
+ -Dwith_openssl=true \
+ -Dwith_pcre2=true \
+ -Dwith_webdav_locks=enabled \
+ -Dwith_webdav_props=enabled \
+ -Dwith_xattr=true \
+ -Dwith_zstd=enabled \
+ . output
+ meson compile -C output
}
check() {
- make check
+ meson test --no-rebuild --print-errorlogs -C output
}
package() {
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
# create dirs
install -d -m755 -o lighttpd -g lighttpd \
@@ -97,12 +106,14 @@ mod_webdav() {
_mv_mod mod_webdav
}
-sha512sums="023d5a54079e710a89a59e259c0b5798103ef6fce4544c36110dc4c5281ef429ef99369923d74123fcf8be37afe622d44cd7149078d21971ff26f3f4ee37c439 lighttpd-1.4.55.tar.xz
-f2f3c5c7731550237fd75a8de66275f427eaf897cffff7ac7ef44178328ad8fad6c4ec6654759bfc665cbaf7991ddcdf0aaa916831c8b6aa440192d57b242038 lighttpd.initd
+sha512sums="
+ee41a72b09614d630174ef832b08c050708f62c0b6299e82b0a5f91a63d62702d31237ae5bb1850f0160b94e36a66af38a2d7abdaa920235265d416d2b0b4015 lighttpd-1.4.73.tar.xz
+a74fb8394fb77fca2a08bdcfc79d4e13de6aca7bc4ed842b7e05f7f3a9cc85dccaa4971ba8fd0edfaa19da8d3870a743b713d9e51f1cbfe5b8e2843bb7fe5346 lighttpd.initd
9d2ab5deb7353ebf290e90936b511941df440859c78589d0bcf130ef69a5e9c79e4d318548b6b118df002083c46f7476230a28954b7a10a9dbd05040e02b1291 lighttpd.confd
0536b4f21d2e8659f7831b45998c13d9f6051ae7ecde13be01f372f837d255bfc4e211de48a7686cc743d53aa9c08ab3f10ec19788896dcf8356b90053ca7a16 lighttpd.logrotate
-e56ee836fa815c98c711f9381a8552ca94e1841aee5ddeee83631c385ccc556e966331499f4784982385f7ed4177062d3349705fd24de2ec5f1544ab1cc424de lighttpd.conf
+f99f109178bc8e60859b01ae7ebaaa63090849fe27f203780bf1e860c2bce997a1b8e6cf4e2a40b5c2f998aac13888aa693dfbfcc8e1bd9be4442a31bcf124d0 lighttpd.conf
a3f2f5763885d7e4f510491b24164e34aaf62bb02daa12991575dc64335c12668355af5bb8d6ce191eb4e9cce95324b1f7c9ba61b323b4e7b50a1e03e021afcf mime-types.conf
27cc638d8068dcf47bd9db44943d1db6c6f4e8e6abd6b42af7cea004b1c093440068541d98c68f8bea70b956713adaf8ed59a4b642dea826ee8620a05f8cfde5 mod_cgi.conf
1d15b84c03fb648a0e67ab5c5411b85478b4454c44bc2959cc96d1700eeadd7ff429520a5f1550db6527267646622dccd3d47d3fd1258869fccaf5c22d4ad4b2 mod_fastcgi.conf
-f9efc4b70d825600f5356c30e57d0b6cac11c01739337f7192c09c2cfd96cb76c8328b11d818ea4c2addc1a6d253975b84700106ae75854d55d0df73e220bd2b mod_fastcgi_fpm.conf"
+f9efc4b70d825600f5356c30e57d0b6cac11c01739337f7192c09c2cfd96cb76c8328b11d818ea4c2addc1a6d253975b84700106ae75854d55d0df73e220bd2b mod_fastcgi_fpm.conf
+"