summaryrefslogtreecommitdiff
path: root/user/lua-expat
diff options
context:
space:
mode:
authorCyberLeo <cyberleo@cyberleo.net>2020-03-28 05:45:52 -0500
committerCyberLeo <cyberleo@cyberleo.net>2020-03-28 05:45:52 -0500
commit9297468fa579836e3a6a381b798feb6b78217c2d (patch)
tree53168212f427afbcf0693b534530a4af803152e9 /user/lua-expat
parenta63cc05c53a6f4c22422dc8c69808b14d87a6f6e (diff)
parentda5a69b65a8791fffa6e93366ee585f87eff136d (diff)
downloadpackages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.gz
packages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.bz2
packages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.xz
packages-9297468fa579836e3a6a381b798feb6b78217c2d.zip
Merge branch 'master' into zfs
Diffstat (limited to 'user/lua-expat')
-rw-r--r--user/lua-expat/32bit.patch11
-rw-r--r--user/lua-expat/APKBUILD22
2 files changed, 23 insertions, 10 deletions
diff --git a/user/lua-expat/32bit.patch b/user/lua-expat/32bit.patch
new file mode 100644
index 000000000..5a09710e1
--- /dev/null
+++ b/user/lua-expat/32bit.patch
@@ -0,0 +1,11 @@
+--- luaexpat-1.3.3/makefile.old 2018-11-27 11:31:28.000000000 +0000
++++ luaexpat-1.3.3/makefile 2020-01-24 06:06:47.843102618 +0000
+@@ -36,7 +36,7 @@
+ -Wpointer-arith \
+ -Wshadow \
+ -Wwrite-strings \
+- -DLUA_C89_NUMBERS
++ -Wno-long-long
+
+ CFLAGS = -fPIC -std=gnu99 $(CWARNS) -ansi -O2 -I$(LUA_INC) -I$(EXPAT_INC)
+ CC = gcc
diff --git a/user/lua-expat/APKBUILD b/user/lua-expat/APKBUILD
index 9c8a6713a..704f89173 100644
--- a/user/lua-expat/APKBUILD
+++ b/user/lua-expat/APKBUILD
@@ -1,9 +1,8 @@
# Contributor: Mika Havela <mika.havela@gmail.com>
# Contribtor: Natanael Copa <ncopa@alpinelinux.org>
-# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Kiyoshi Aman <adelie@aerdan.vulpine.house>
pkgname=lua-expat
-_name=expat
-pkgver=1.3.0
+pkgver=1.3.3
pkgrel=0
pkgdesc="SAX XML parser based on the Expat library"
url="https://matthewwild.co.uk/projects/luaexpat/"
@@ -11,22 +10,25 @@ arch="all"
license="MIT"
depends="lua5.3"
makedepends="lua5.3-dev expat-dev"
-source="http://matthewwild.co.uk/projects/luaexpat/luaexpat-$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/tomasguisasola/luaexpat/archive/v1.3.3.tar.gz
+ 32bit.patch
+ "
builddir="$srcdir/luaexpat-$pkgver"
build() {
- cd "$builddir"
make LUA_V=5.3
}
check() {
- cd "$builddir"
- LUA_CPATH="./src/?.so" lua tests/test.lua
+ LUA_CPATH="./src/?.so.1.3.3" lua tests/test.lua
}
package() {
- cd "$builddir"
- make LUA_V=5.3 DESTDIR="$pkgdir" install
+ make \
+ LUA_LIBDIR="$pkgdir"/usr/lib/lua5.3 \
+ LUA_DIR="$pkgdir"/usr/share/lua5.3 \
+ LUA_V=5.3 DESTDIR="$pkgdir" install
}
-sha512sums="91884653310e2dc89ade6d1653875ac8607640a21853d3ccb1fd0f833812e41981fad5c40101732ec249104d2c50c9a332208d1e44423b8428065a223c60b4ae luaexpat-1.3.0.tar.gz"
+sha512sums="aa3f730c64cae3791fc1125302178ec2398d2380e8ec0e65ca4b29f532f181f149baaf555bf687e502b28726d3fd0baafd4f73cf26f04f625d18bbaddb043d63 lua-expat-1.3.3.tar.gz
+ac5b05991dfe36bcc0c9ff7570110dbb1face387c0b65e4735b99cedaff5e29311a919b5e8ce6dae2ac674eadd2fa0bea6ec547754071d325dcce6460eeef36e 32bit.patch"