summaryrefslogtreecommitdiff
path: root/user/lua-yaml/APKBUILD
diff options
context:
space:
mode:
authorCyberLeo <cyberleo@cyberleo.net>2020-03-28 05:45:52 -0500
committerCyberLeo <cyberleo@cyberleo.net>2020-03-28 05:45:52 -0500
commit9297468fa579836e3a6a381b798feb6b78217c2d (patch)
tree53168212f427afbcf0693b534530a4af803152e9 /user/lua-yaml/APKBUILD
parenta63cc05c53a6f4c22422dc8c69808b14d87a6f6e (diff)
parentda5a69b65a8791fffa6e93366ee585f87eff136d (diff)
downloadpackages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.gz
packages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.bz2
packages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.xz
packages-9297468fa579836e3a6a381b798feb6b78217c2d.zip
Merge branch 'master' into zfs
Diffstat (limited to 'user/lua-yaml/APKBUILD')
-rw-r--r--user/lua-yaml/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/user/lua-yaml/APKBUILD b/user/lua-yaml/APKBUILD
new file mode 100644
index 000000000..f252b3a7b
--- /dev/null
+++ b/user/lua-yaml/APKBUILD
@@ -0,0 +1,25 @@
+# Contributor: Alyx Wolcott <alyx@leuhta.com>
+# Maintainer: Alyx Wolcott <alyx@leuhta.com>
+pkgname=lua-yaml
+pkgver=6.2.4
+pkgrel=0
+pkgdesc="LibYAML binding for Lua"
+url="https://gvvaughan.github.io/lyaml/"
+arch="all"
+options="!check" # No tests, sweet.
+license="MIT"
+depends="lua5.3"
+makedepends="lua5.3-dev yaml-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/gvvaughan/lyaml/archive/v$pkgver.tar.gz"
+builddir="$srcdir/lyaml-$pkgver"
+
+build () {
+ ./build-aux/luke PREFOX=$pkgdir/usr VERSION="${pkgver}"
+}
+
+package() {
+ mkdir -p $pkgdir/usr
+ ./build-aux/luke PREFIX=$pkgdir/usr install
+}
+
+sha512sums="92dea86a3b1d648093d2134ea4c558432b0861942aa141359d1ca9d7bc55f33a62bb38e12fd653d69139e0a6f0ea6202a9e8c57f750a065d35f0dd674eacaf8a lua-yaml-6.2.4.tar.gz"