summaryrefslogtreecommitdiff
path: root/user/lxqt-config/revert-kscren-bump.patch
diff options
context:
space:
mode:
authorSíle Ekaterin Liszka <sheila@vulpine.house>2023-11-26 02:53:54 -0800
committerA. Wilcox <awilcox@wilcox-tech.com>2023-11-27 09:59:05 +0000
commit54b8af5ec8302123efb8c8dffdc76c621b6d650a (patch)
tree02d9a6ef13e20b25d838704ff48b84f3426e8edd /user/lxqt-config/revert-kscren-bump.patch
parent005dea5cbaf4e342439dd7fee001271377cbf552 (diff)
downloadpackages-54b8af5ec8302123efb8c8dffdc76c621b6d650a.tar.gz
packages-54b8af5ec8302123efb8c8dffdc76c621b6d650a.tar.bz2
packages-54b8af5ec8302123efb8c8dffdc76c621b6d650a.tar.xz
packages-54b8af5ec8302123efb8c8dffdc76c621b6d650a.zip
user/lxqt-config: upgrade to 1.4.0
The patch accompanying this upgrade should be removed when kscreen is bumped.
Diffstat (limited to 'user/lxqt-config/revert-kscren-bump.patch')
-rw-r--r--user/lxqt-config/revert-kscren-bump.patch57
1 files changed, 57 insertions, 0 deletions
diff --git a/user/lxqt-config/revert-kscren-bump.patch b/user/lxqt-config/revert-kscren-bump.patch
new file mode 100644
index 000000000..bb9461b72
--- /dev/null
+++ b/user/lxqt-config/revert-kscren-bump.patch
@@ -0,0 +1,57 @@
+diff '--color=auto' -Nurd lxqt-config-1.4.0/CMakeLists.txt lxqt-config-1.4.0.new/CMakeLists.txt
+--- lxqt-config-1.4.0/CMakeLists.txt 2023-11-05 03:36:31.000000000 -0800
++++ lxqt-config-1.4.0.new/CMakeLists.txt 2023-11-26 02:44:43.889325759 -0800
+@@ -26,7 +26,7 @@
+ set(CMAKE_AUTORCC ON)
+
+ set(KF5_MINIMUM_VERSION "5.36.0")
+-set(KF5SCREEN_MINIMUM_VERSION "5.27.0")
++set(KF5SCREEN_MINIMUM_VERSION "5.2.0")
+ set(LXQT_MINIMUM_VERSION "1.4.0")
+ set(QT_MINIMUM_VERSION "5.15.0")
+
+diff '--color=auto' -Nurd lxqt-config-1.4.0/lxqt-config-monitor/kscreenutils.cpp lxqt-config-1.4.0.new/lxqt-config-monitor/kscreenutils.cpp
+--- lxqt-config-1.4.0/lxqt-config-monitor/kscreenutils.cpp 2023-11-05 03:36:31.000000000 -0800
++++ lxqt-config-1.4.0.new/lxqt-config-monitor/kscreenutils.cpp 2023-11-26 02:45:27.458971215 -0800
+@@ -63,7 +63,7 @@
+ output->setPos(pos);
+ output->setEnabled(true);
+ //first left one as primary
+- output->setPriority(width == 0 ? 1 : 0);
++ output->setPrimary(width == 0);
+ KScreen::ModePtr mode(output->currentMode());
+ //if (!mode)
+ {
+diff '--color=auto' -Nurd lxqt-config-1.4.0/lxqt-config-monitor/loadsettings.cpp lxqt-config-1.4.0.new/lxqt-config-monitor/loadsettings.cpp
+--- lxqt-config-1.4.0/lxqt-config-monitor/loadsettings.cpp 2023-11-05 03:36:31.000000000 -0800
++++ lxqt-config-1.4.0.new/lxqt-config-monitor/loadsettings.cpp 2023-11-26 02:46:05.328663054 -0800
+@@ -133,7 +133,7 @@
+ if( !output->isConnected() )
+ continue;
+ output->setEnabled( monitor.enabled );
+- output->setPriority( monitor.primary ? 1 : 0 );
++ output->setPrimary( monitor.primary );
+ output->setPos( QPoint(monitor.xPos, monitor.yPos) );
+ output->setRotation( (KScreen::Output::Rotation)(monitor.rotation) );
+ // output->setCurrentModeId could fail. KScreen sometimes changes mode Id.
+diff '--color=auto' -Nurd lxqt-config-1.4.0/lxqt-config-monitor/monitorwidget.cpp lxqt-config-1.4.0.new/lxqt-config-monitor/monitorwidget.cpp
+--- lxqt-config-1.4.0/lxqt-config-monitor/monitorwidget.cpp 2023-11-05 03:36:31.000000000 -0800
++++ lxqt-config-1.4.0.new/lxqt-config-monitor/monitorwidget.cpp 2023-11-26 02:47:02.698196214 -0800
+@@ -138,7 +138,7 @@
+ if (config->connectedOutputs().count() == 1) {
+ setOnlyMonitor(true);
+ // There isn't always a primary output. Gross.
+- output->setPriority(1);
++ output->setPrimary(true);
+ }
+
+ ui.xPosSpinBox->setValue(output->pos().x());
+@@ -208,7 +208,7 @@
+ ui.xPosSpinBox->setVisible(idx == ExtendDisplay);
+ ui.yPosSpinBox->setVisible(idx == ExtendDisplay);
+
+- output->setPriority(idx == PrimaryDisplay ? 1 : 0);
++ output->setPrimary(idx == PrimaryDisplay);
+ if(idx == PrimaryDisplay)
+ emit primaryOutputChanged(this);
+ }