summaryrefslogtreecommitdiff
path: root/user/lxqt-notificationd
diff options
context:
space:
mode:
authorKiyoshi Aman <kiyoshi.aman+apkfission@gmail.com>2018-06-06 13:51:08 -0500
committerKiyoshi Aman <kiyoshi.aman+apkfission@gmail.com>2018-06-06 13:51:08 -0500
commit7613c242717480beeb1940d211eb7abb568c34ee (patch)
tree7400c40d67c9122313cb0196b4b744df2f1a5686 /user/lxqt-notificationd
parentbf977830b1ad079a0a55ffd516fa29c00bec7ca1 (diff)
downloadpackages-7613c242717480beeb1940d211eb7abb568c34ee.tar.gz
packages-7613c242717480beeb1940d211eb7abb568c34ee.tar.bz2
packages-7613c242717480beeb1940d211eb7abb568c34ee.tar.xz
packages-7613c242717480beeb1940d211eb7abb568c34ee.zip
user/lxqt-notificationd: bump to 0.13.0
Diffstat (limited to 'user/lxqt-notificationd')
-rw-r--r--user/lxqt-notificationd/APKBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/user/lxqt-notificationd/APKBUILD b/user/lxqt-notificationd/APKBUILD
index 8a91eeb05..ef98f85db 100644
--- a/user/lxqt-notificationd/APKBUILD
+++ b/user/lxqt-notificationd/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
pkgname=lxqt-notificationd
-pkgver=0.12.0
+pkgver=0.13.0
pkgrel=0
pkgdesc="Daemon for notifications in LXQt."
url="http://lxqt.org"
@@ -9,9 +9,9 @@ arch="all"
license="LGPL-2.1+"
depends=""
depends_dev=""
-makedepends="cmake extra-cmake-modules liblxqt-dev>=0.12.0 lxqt-build-tools qt5-qttools-dev kwindowsystem-dev $depends_dev"
+makedepends="cmake extra-cmake-modules liblxqt-dev>=0.12.0 lxqt-build-tools>=0.5.0 qt5-qttools-dev kwindowsystem-dev $depends_dev"
install=""
-source="https://github.com/lxde/lxqt-notificationd/releases/download/$pkgver/lxqt-notificationd-$pkgver.tar.xz"
+source="https://github.com/lxqt/lxqt-notificationd/releases/download/$pkgver/lxqt-notificationd-$pkgver.tar.xz"
builddir="$srcdir/lxqt-notificationd-$pkgver"
build() {
@@ -19,6 +19,7 @@ build() {
if [ "$CBUILD" != "$CHOST" ]; then
CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
+ mkdir -p build && cd build
cmake \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
@@ -27,18 +28,18 @@ build() {
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
-DCMAKE_C_FLAGS="$CFLAGS" \
-DPULL_TRANSLATIONS=False \
- ${CMAKE_CROSSOPTS}
+ ${CMAKE_CROSSOPTS} ..
make
}
check() {
- cd "$builddir"
+ cd "$builddir"/build
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
- cd "$builddir"
+ cd "$builddir"/build
make DESTDIR="$pkgdir" install
}
-sha512sums="89243c011b8d5a96d3f407a71d14a8c6c8792cded1d92dd442991b1acf73deb884e0ef668a2806e0348f95affbb408f913e61355c84ba406d20f43fedaf2285a lxqt-notificationd-0.12.0.tar.xz"
+sha512sums="2bc75b840a666e013d914f08719680cf3af7430a6acfb5072facff8bdc964aeef1d5227c68b5a5c5d8a6d6c572632105e3f2f04c517d8e8669eb40b5a0cf0f4d lxqt-notificationd-0.13.0.tar.xz"