summaryrefslogtreecommitdiff
path: root/user/mac-fdisk/APKBUILD
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-11 01:54:54 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-11 01:54:54 +0000
commit21c4b84eb30afc752dd0ba5965c61dfc3bebac3d (patch)
tree1ca6f553222cbe4809067ffa24d6efafdae7b8df /user/mac-fdisk/APKBUILD
parent5efd7da9a9a79f82b4621cfd34fb8200c51f485a (diff)
downloadpackages-21c4b84eb30afc752dd0ba5965c61dfc3bebac3d.tar.gz
packages-21c4b84eb30afc752dd0ba5965c61dfc3bebac3d.tar.bz2
packages-21c4b84eb30afc752dd0ba5965c61dfc3bebac3d.tar.xz
packages-21c4b84eb30afc752dd0ba5965c61dfc3bebac3d.zip
user/*: Modernise / fix syntax / metadata / deps
Diffstat (limited to 'user/mac-fdisk/APKBUILD')
-rw-r--r--user/mac-fdisk/APKBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/user/mac-fdisk/APKBUILD b/user/mac-fdisk/APKBUILD
index 1120b249b..fa5b7d902 100644
--- a/user/mac-fdisk/APKBUILD
+++ b/user/mac-fdisk/APKBUILD
@@ -7,8 +7,8 @@ pkgrel=2
pkgdesc="68K and PowerPC fixed disk partitioning utility"
url="https://adelielinux.org/"
arch="all !aarch64" # Literally does not support this arch.
-license="GPL-2.0"
options="!check" # No test suite.
+license="GPL-2.0"
depends=""
makedepends="linux-headers"
subpackages="$pkgname-doc"
@@ -23,16 +23,15 @@ source="https://distfiles.adelielinux.org/source/mac-fdisk_0.1.orig.tar.gz
mac-fdisk-large-disk-support.patch
mac-fdisk-largerthan2gb.patch
mac-fdisk-non-glibc-support.patch
- flush-stdout.patch"
+ flush-stdout.patch
+ "
builddir="$srcdir/$pkgname-$_pkgver.orig"
build() {
- cd "$builddir"
make CFLAGS="-D_GNU_SOURCE"
}
package() {
- cd "$builddir"
mkdir -p "$pkgdir"/sbin
make DESTDIR="$pkgdir" install