summaryrefslogtreecommitdiff
path: root/user/mac-fdisk/APKBUILD
diff options
context:
space:
mode:
authorCyberLeo <cyberleo@cyberleo.net>2020-03-28 05:45:52 -0500
committerCyberLeo <cyberleo@cyberleo.net>2020-03-28 05:45:52 -0500
commit9297468fa579836e3a6a381b798feb6b78217c2d (patch)
tree53168212f427afbcf0693b534530a4af803152e9 /user/mac-fdisk/APKBUILD
parenta63cc05c53a6f4c22422dc8c69808b14d87a6f6e (diff)
parentda5a69b65a8791fffa6e93366ee585f87eff136d (diff)
downloadpackages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.gz
packages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.bz2
packages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.xz
packages-9297468fa579836e3a6a381b798feb6b78217c2d.zip
Merge branch 'master' into zfs
Diffstat (limited to 'user/mac-fdisk/APKBUILD')
-rw-r--r--user/mac-fdisk/APKBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/user/mac-fdisk/APKBUILD b/user/mac-fdisk/APKBUILD
index 1120b249b..fa5b7d902 100644
--- a/user/mac-fdisk/APKBUILD
+++ b/user/mac-fdisk/APKBUILD
@@ -7,8 +7,8 @@ pkgrel=2
pkgdesc="68K and PowerPC fixed disk partitioning utility"
url="https://adelielinux.org/"
arch="all !aarch64" # Literally does not support this arch.
-license="GPL-2.0"
options="!check" # No test suite.
+license="GPL-2.0"
depends=""
makedepends="linux-headers"
subpackages="$pkgname-doc"
@@ -23,16 +23,15 @@ source="https://distfiles.adelielinux.org/source/mac-fdisk_0.1.orig.tar.gz
mac-fdisk-large-disk-support.patch
mac-fdisk-largerthan2gb.patch
mac-fdisk-non-glibc-support.patch
- flush-stdout.patch"
+ flush-stdout.patch
+ "
builddir="$srcdir/$pkgname-$_pkgver.orig"
build() {
- cd "$builddir"
make CFLAGS="-D_GNU_SOURCE"
}
package() {
- cd "$builddir"
mkdir -p "$pkgdir"/sbin
make DESTDIR="$pkgdir" install