summaryrefslogtreecommitdiff
path: root/user/marble
diff options
context:
space:
mode:
authorJohn Ogness <adelielinux@ogness.net>2021-01-12 21:47:50 +0100
committerJohn Ogness <adelielinux@ogness.net>2021-01-12 22:17:27 +0100
commita3e363872cbfe68b0e7d876b149adb42716afb89 (patch)
treebfd90fe19f25150679ceea67baf18c9a613b9dc2 /user/marble
parent3465fcf878a4f0e00a9378a4299eaa48a0af5bea (diff)
downloadpackages-a3e363872cbfe68b0e7d876b149adb42716afb89.tar.gz
packages-a3e363872cbfe68b0e7d876b149adb42716afb89.tar.bz2
packages-a3e363872cbfe68b0e7d876b149adb42716afb89.tar.xz
packages-a3e363872cbfe68b0e7d876b149adb42716afb89.zip
user/marble: move soname symlinks to -libs
The default_libs() implementation does not put the soname symlinks into the -libs subpackage. They are left in the main package. This renders the -libs subpackage useless as a runtime dependency for other packages. Also move the soname symlinks to /usr/lib using a custom libs() implementation. Signed-off-by: John Ogness <adelielinux@ogness.net>
Diffstat (limited to 'user/marble')
-rw-r--r--user/marble/APKBUILD9
1 files changed, 9 insertions, 0 deletions
diff --git a/user/marble/APKBUILD b/user/marble/APKBUILD
index 2f32e4c3f..7e452f5cf 100644
--- a/user/marble/APKBUILD
+++ b/user/marble/APKBUILD
@@ -32,6 +32,15 @@ build() {
make
}
+libs() {
+ pkgdesc="$pkgdesc (libraries)"
+ local file=
+ for file in "$pkgdir"/usr/lib/lib*.so.[0-9]*; do
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$file" "$subpkgdir"/usr/lib/
+ done
+}
+
package() {
make DESTDIR="$pkgdir" install
}