summaryrefslogtreecommitdiff
path: root/user/mariadb
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-07-06 19:39:08 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-07-06 19:39:08 +0000
commit262e5405f607d5ef06be1eef5033cb80fbe58461 (patch)
treeec8df40a1d5b34b1ca21286b2a9670192d86193a /user/mariadb
parentcd6af0265e8b5020c6b56efb0dc7cd27be65125d (diff)
downloadpackages-262e5405f607d5ef06be1eef5033cb80fbe58461.tar.gz
packages-262e5405f607d5ef06be1eef5033cb80fbe58461.tar.bz2
packages-262e5405f607d5ef06be1eef5033cb80fbe58461.tar.xz
packages-262e5405f607d5ef06be1eef5033cb80fbe58461.zip
user/mariadb: don't dep on numactl or split debug
Diffstat (limited to 'user/mariadb')
-rw-r--r--user/mariadb/APKBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/user/mariadb/APKBUILD b/user/mariadb/APKBUILD
index e5e9c2f83..9c80ecff0 100644
--- a/user/mariadb/APKBUILD
+++ b/user/mariadb/APKBUILD
@@ -7,14 +7,18 @@ pkgrel=0
pkgdesc="Open source database server"
url="https://mariadb.org/"
arch="all"
+options="suid" # required for pam_auth plugin, which is needed for
+ # mysql_install_db to work
+options="$options !dbg" # abuild can't handle splitting -dbg with the way
+ # this build's package() function works.
license="GPL-2.0-only"
pkgusers="mysql"
pkggroups="mysql"
depends="$pkgname-common"
depends_dev="openssl-dev zlib-dev"
makedepends="$depends_dev bison cmake curl-dev libaio-dev libarchive-dev
- libedit-dev libevent-dev libexecinfo-dev libxml2-dev numactl-dev
- ncurses-dev linux-pam-dev pcre-dev xz-dev"
+ libedit-dev libevent-dev libexecinfo-dev libxml2-dev ncurses-dev
+ linux-pam-dev pcre-dev xz-dev"
_mytopdeps="perl perl-dbi perl-dbd-mysql perl-getopt-long perl-socket
perl-term-readkey"
subpackages="$pkgname-client $pkgname-server $pkgname-libs $pkgname-embedded
@@ -25,9 +29,6 @@ source="https://downloads.mariadb.org/interstitial/mariadb-$pkgver/source/mariad
mariadb-server.limits
"
-options="suid" # required for pam_auth plugin, which is needed for
- # mysql_install_db to work
-
build() {
if [ "$CBUILD" != "$CHOST" ]; then
CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"