summaryrefslogtreecommitdiff
path: root/user/mariadb
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-07-07 00:26:57 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-07-07 00:26:57 +0000
commitcd9523f0263a1aaffc614041d663f7e791849740 (patch)
tree30ced1f284eee9e30605ab1a1915caaf776d20ca /user/mariadb
parent786e32e39ee8f5b809e89d63133749608b0c5710 (diff)
downloadpackages-cd9523f0263a1aaffc614041d663f7e791849740.tar.gz
packages-cd9523f0263a1aaffc614041d663f7e791849740.tar.bz2
packages-cd9523f0263a1aaffc614041d663f7e791849740.tar.xz
packages-cd9523f0263a1aaffc614041d663f7e791849740.zip
user/mariadb: actually disable evil things instead of just talking about it
Diffstat (limited to 'user/mariadb')
-rw-r--r--user/mariadb/APKBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/user/mariadb/APKBUILD b/user/mariadb/APKBUILD
index ddc4577a4..0b211f2ce 100644
--- a/user/mariadb/APKBUILD
+++ b/user/mariadb/APKBUILD
@@ -104,6 +104,12 @@ build() {
-DCONNECT_WITH_JDBC=NO \
-DCONNECT_WITH_LIBXML2=system "
+ # non-portable things, things that don't work on musl, BE, 32-bit etc
+ local _evil="\
+ -DPLUGIN_MROONGA=NO \
+ -DPLUGIN_ROCKSDB=NO \
+ -DPLUGIN_TOKUDB=NO "
+
local _system_libs="\
-DWITH_LIBARCHIVE=system \
-DWITH_PCRE=system \
@@ -112,12 +118,6 @@ build() {
-DWITH_EXTERNAL_ZLIB=YES \
-DCONC_WITH_EXTERNAL_ZLIB=YES "
- # non-portable things, things that don't work on musl, BE, 32-bit etc
- local _evil="\
- -DPLUGIN_MROONGA=NO \
- -DPLUGIN_ROCKSDB=NO \
- -DPLUGIN_TOKUDB=NO "
-
local _system_paths="\
-DCMAKE_INSTALL_PREFIX=/usr \
-DSYSCONFDIR=/etc/mysql \
@@ -144,6 +144,7 @@ build() {
${_plugins}\
${_innodb}\
${_connect}\
+ ${_evil}\
${_system_libs}\
${_system_paths}\
${CMAKE_CROSSOPTS}" | tr -d '\t')