summaryrefslogtreecommitdiff
path: root/user/mednafen
diff options
context:
space:
mode:
authorHorst G. Burkhardt <horst@adelielinux.org>2018-04-30 01:10:18 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-10-23 19:19:39 +0000
commita00c2a6be761c7e9753549cf4d5b7b1b6f168b33 (patch)
tree2baac82d77d3e438e87c35fa1e2cd3a4fa06449f /user/mednafen
parent50a425fa382459251c3e37ab695ff803570e2958 (diff)
downloadpackages-a00c2a6be761c7e9753549cf4d5b7b1b6f168b33.tar.gz
packages-a00c2a6be761c7e9753549cf4d5b7b1b6f168b33.tar.bz2
packages-a00c2a6be761c7e9753549cf4d5b7b1b6f168b33.tar.xz
packages-a00c2a6be761c7e9753549cf4d5b7b1b6f168b33.zip
user/mednafen: new package
Diffstat (limited to 'user/mednafen')
-rw-r--r--user/mednafen/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/user/mednafen/APKBUILD b/user/mednafen/APKBUILD
new file mode 100644
index 000000000..ccc64e8e7
--- /dev/null
+++ b/user/mednafen/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Horst Burkhardt <horst@adelielinux.org>
+# Maintainer: Horst Burkhardt <horst@adelielinux.org>
+pkgname=mednafen
+pkgver=1.21.3
+pkgrel=0
+pkgdesc="an emulator for various home gaming consoles"
+url="https://mednafen.github.io/"
+arch="all !s390x"
+options="!check" # mednafen does not ship actual tests
+subpackages="$pkgname-doc"
+license="GPL-2.0-only"
+depends=""
+makedepends="alsa-lib-dev flac-dev libogg-dev libsndfile-dev libvorbis-dev
+ lzo-dev sdl2-dev zlib-dev"
+source="https://mednafen.github.io/releases/files/$pkgname-$pkgver.tar.xz"
+builddir="$srcdir/$pkgname"
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr --enable-ss=no
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="987c14edae68901f8a693c9f7317063daf4274bb0b650ed05cd01cf4ceb38d76e6ff5446c324447f73727096c74d0bf7f545cdeadfb6291d67656d659de26715 mednafen-1.21.3.tar.xz"