summaryrefslogtreecommitdiff
path: root/user/mimetic
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-08-01 05:44:12 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-08-01 05:44:23 +0000
commit3579eebe207eccdf15b1a026e7e8f7f75dc93511 (patch)
treef9685ede95795288796c34bcbd2134fac4a4e8da /user/mimetic
parent28b998ab6922ec9202adef85d0a9723f2299c066 (diff)
downloadpackages-3579eebe207eccdf15b1a026e7e8f7f75dc93511.tar.gz
packages-3579eebe207eccdf15b1a026e7e8f7f75dc93511.tar.bz2
packages-3579eebe207eccdf15b1a026e7e8f7f75dc93511.tar.xz
packages-3579eebe207eccdf15b1a026e7e8f7f75dc93511.zip
user/mimetic: fix build on PowerPC arches, modernise
Diffstat (limited to 'user/mimetic')
-rw-r--r--user/mimetic/APKBUILD12
-rw-r--r--user/mimetic/signedness.patch37
2 files changed, 41 insertions, 8 deletions
diff --git a/user/mimetic/APKBUILD b/user/mimetic/APKBUILD
index 6c3a4c542..c69f27270 100644
--- a/user/mimetic/APKBUILD
+++ b/user/mimetic/APKBUILD
@@ -8,12 +8,11 @@ url="http://www.codesink.org/mimetic_mime_library.html"
arch="all"
license="MIT"
depends=""
-depends_dev=""
-makedepends="$depends_dev"
-install=""
+makedepends="doxygen"
subpackages="$pkgname-dev"
source="http://www.codesink.org/download/mimetic-$pkgver.tar.gz
fix-compile.patch
+ signedness.patch
"
prepare() {
@@ -43,10 +42,7 @@ package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
}
-doc() {
- depends="doxygen"
- default_doc
-}
sha512sums="4157eecb3e26af314d475c91192a357d6da35271a07a07b037d5037e9af84952ce2636874e86df0e94e8887dcfdb8f594a1ba04e6448181e436b0e2675f48f58 mimetic-0.9.8.tar.gz
-26badbaea0e9392080ece1cfda41d16a4fa87850e92edb4120e0a080fcebeeebaf28adb0fc73ba56ecacfc670bc315b2255c9c101471beb09068b1b4c4c8c473 fix-compile.patch"
+26badbaea0e9392080ece1cfda41d16a4fa87850e92edb4120e0a080fcebeeebaf28adb0fc73ba56ecacfc670bc315b2255c9c101471beb09068b1b4c4c8c473 fix-compile.patch
+d92c719134064e545e7b63f56bfc6b2898c82766a4540230ac5273b1380ef4546d220d95faa99d7b9c01508650a361b7473ad74c9a79262cb423277ca83a36b2 signedness.patch"
diff --git a/user/mimetic/signedness.patch b/user/mimetic/signedness.patch
new file mode 100644
index 000000000..95af182d3
--- /dev/null
+++ b/user/mimetic/signedness.patch
@@ -0,0 +1,37 @@
+--- mimetic-0.9.8/mimetic/codec/base64.h.old 2014-06-17 08:12:00.000000000 +0000
++++ mimetic-0.9.8/mimetic/codec/base64.h 2018-08-01 05:37:10.280000000 +0000
+@@ -19,8 +19,8 @@
+ enum { LF = 0xA, CR = 0xD, NL = '\n' };
+ enum { default_maxlen = 76 };
+ enum { eq_sign = 100 };
+- static const char sEncTable[];
+- static const char sDecTable[];
++ static const signed char sEncTable[];
++ static const signed char sDecTable[];
+ static const int sDecTableSz;
+ public:
+ class Encoder; class Decoder;
+--- mimetic-0.9.8/mimetic/codec/base64.cxx.old 2014-06-17 08:12:00.000000000 +0000
++++ mimetic-0.9.8/mimetic/codec/base64.cxx 2018-08-01 05:36:23.010000000 +0000
+@@ -8,12 +8,12 @@
+
+ using namespace mimetic;
+
+-const char Base64::sEncTable[] =
++const signed char Base64::sEncTable[] =
+ "ABCDEFGHIJKLMNOPQRSTUVWXYZ"
+ "abcdefghijklmnopqrstuvwxyz"
+ "0123456789+/=";
+
+-const char Base64::sDecTable[] = {
++const signed char Base64::sDecTable[] = {
+ -1,-1,-1,-1,-1,-1,-1,-1,-1,-1,
+ -1,-1,-1,-1,-1,-1,-1,-1,-1,-1,
+ -1,-1,-1,-1,-1,-1,-1,-1,-1,-1,
+@@ -29,5 +29,5 @@
+ 49,50,51,-1
+ };
+
+-const int Base64::sDecTableSz = sizeof(Base64::sDecTable) / sizeof(char);
++const int Base64::sDecTableSz = sizeof(Base64::sDecTable) / sizeof(signed char);
+