summaryrefslogtreecommitdiff
path: root/user/mistserver/add-dtls-srtp-cmake-option.patch
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2023-04-11 04:18:05 +0000
committerZach van Rijn <me@zv.io>2023-04-11 05:01:51 +0000
commite07fed402514b18f3399730744b24dfc82c5c155 (patch)
tree5942854099fab2c28236eee2a5029522b7d2ddc1 /user/mistserver/add-dtls-srtp-cmake-option.patch
parente0b5793834806afa896cbd1e4ee3876fcac78edc (diff)
downloadpackages-e07fed402514b18f3399730744b24dfc82c5c155.tar.gz
packages-e07fed402514b18f3399730744b24dfc82c5c155.tar.bz2
packages-e07fed402514b18f3399730744b24dfc82c5c155.tar.xz
packages-e07fed402514b18f3399730744b24dfc82c5c155.zip
user/mistserver: bump { 2.18.1 --> 3.1 }. fixes #991.
This is upstream mistserver plus a handful of patches to support mbedTLS 3.x. See #991 for more information. Grows a dependency on libsrtp-dev (new package). Concurrency is capped at 2 threads to avoid race conditions until someone figures out why the build scripts are racy. Tests are kneecapped until someone figures out how to fix.
Diffstat (limited to 'user/mistserver/add-dtls-srtp-cmake-option.patch')
-rw-r--r--user/mistserver/add-dtls-srtp-cmake-option.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/user/mistserver/add-dtls-srtp-cmake-option.patch b/user/mistserver/add-dtls-srtp-cmake-option.patch
new file mode 100644
index 000000000..8704b5a08
--- /dev/null
+++ b/user/mistserver/add-dtls-srtp-cmake-option.patch
@@ -0,0 +1,15 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 6af16808..a12aa8cf 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -91,6 +91,10 @@ else()
+ message("SSL/TLS support is turned OFF")
+ endif()
+
++if (USE_MBEDTLS_SSL_DTLS_SRTP)
++ add_definitions(-DHAVE_UPSTREAM_MBEDTLS_SRTP=1)
++endif()
++
+ if (DEFINED DATASIZE )
+ add_definitions(-DSHM_DATASIZE=${DATASIZE})
+ endif()