summaryrefslogtreecommitdiff
path: root/user/mosquitto
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-13 05:06:15 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-01-13 05:06:15 +0000
commit24bb84929c1fcdfd3cab369b94ce63b02b7e3c7c (patch)
treeb03fccc2afaeda4b1944b72b8669ff70da289996 /user/mosquitto
parenta63982012ac4930f2c911876da655e6a5329d4b1 (diff)
downloadpackages-24bb84929c1fcdfd3cab369b94ce63b02b7e3c7c.tar.gz
packages-24bb84929c1fcdfd3cab369b94ce63b02b7e3c7c.tar.bz2
packages-24bb84929c1fcdfd3cab369b94ce63b02b7e3c7c.tar.xz
packages-24bb84929c1fcdfd3cab369b94ce63b02b7e3c7c.zip
user/mosquitto: Bump to 1.6.8
Diffstat (limited to 'user/mosquitto')
-rw-r--r--user/mosquitto/APKBUILD12
-rw-r--r--user/mosquitto/python3.patch48
2 files changed, 6 insertions, 54 deletions
diff --git a/user/mosquitto/APKBUILD b/user/mosquitto/APKBUILD
index e7cd25057..7e19f62f4 100644
--- a/user/mosquitto/APKBUILD
+++ b/user/mosquitto/APKBUILD
@@ -2,15 +2,16 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=mosquitto
-pkgver=1.6.6
+pkgver=1.6.8
pkgrel=0
pkgdesc="An Open Source MQTT Broker"
url="https://mosquitto.org/"
arch="all"
+options="!check" # "Connection refused" during testing.
license="EPL-1.0 AND EDL-1.0 AND MIT AND BSD-3-Clause"
depends=""
-makedepends="c-ares-dev openssl-dev util-linux-dev"
checkdepends="python3"
+makedepends="c-ares-dev openssl-dev util-linux-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs $pkgname-openrc
$pkgname-clients"
install="$pkgname.pre-install"
@@ -18,7 +19,7 @@ source="http://mosquitto.org/files/source/$pkgname-$pkgver.tar.gz
mosquitto.initd
disable-flaky-test.patch
openrc-conf.patch
- python3.patch"
+ "
# secfixes:
# 1.6.6-r0:
@@ -73,8 +74,7 @@ clients() {
mv "$pkgdir"/usr/bin/mosquitto_[ps]ub "$subpkgdir"/usr/bin/
}
-sha512sums="ea6ba7b57773c8f4a59e708ae305a0e38ca85df94854410b29cccddbe10bbb91c2ea5e827fefb3f57cb4fce188ab9c3021804f1ae398b7fd5e9e965354b68bc1 mosquitto-1.6.6.tar.gz
+sha512sums="c15897df4e0979ee29a1e67cc671f56db600a078e9eb0bea376248b3f53b13ceed36616ad3678e2c9e07d6834a6d75e4efca2c40086069c1546e0223be04c071 mosquitto-1.6.8.tar.gz
681fddc737b3ef3e6c052f0c854a730df290352640a18a63e23ef83d14c425558aff87805d1eb95e44de101b5df48872173af9f5414464ffa8cf727ea2c0491e mosquitto.initd
3886171e36f759a717aa6626d5b8dbd392963c737d5de28b4d52b81359008927b99ff7a0ca82f56a0e5deaed4585571759ba9216336a664fd346845837c2bc18 disable-flaky-test.patch
-b07f9bec2751ab32c43f53e74d8fca18dbf2d7ce7f8fab562dbcf75de19609ba6219d735ac504697404e0ed36613a14074e3a19e735297195877798f778d337a openrc-conf.patch
-078197e6c3e59b664f5fdd1e4a4f669c9a76ab84fe4a5d8602ac80406b85c4e1cce29d9372e76d995155b74abb438d0dc0cdcdb98251fb904122073c4088d76a python3.patch"
+b07f9bec2751ab32c43f53e74d8fca18dbf2d7ce7f8fab562dbcf75de19609ba6219d735ac504697404e0ed36613a14074e3a19e735297195877798f778d337a openrc-conf.patch"
diff --git a/user/mosquitto/python3.patch b/user/mosquitto/python3.patch
deleted file mode 100644
index f348cbc3e..000000000
--- a/user/mosquitto/python3.patch
+++ /dev/null
@@ -1,48 +0,0 @@
---- mosquitto-1.6.4/test/broker/09-extended-auth-change-username.py.old 2019-08-01 19:50:01.000000000 +0000
-+++ mosquitto-1.6.4/test/broker/09-extended-auth-change-username.py 2019-08-27 22:20:08.560518752 +0000
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
-
- # Check whether an extended auth plugin can change the username of a client.
-
---- mosquitto-1.6.4/test/broker/09-extended-auth-multistep-reauth.py.old 2019-08-01 19:50:01.000000000 +0000
-+++ mosquitto-1.6.4/test/broker/09-extended-auth-multistep-reauth.py 2019-08-27 22:22:11.530519618 +0000
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
-
- from mosq_test_helper import *
-
---- mosquitto-1.6.4/test/broker/09-extended-auth-multistep.py.old 2019-08-01 19:50:01.000000000 +0000
-+++ mosquitto-1.6.4/test/broker/09-extended-auth-multistep.py 2019-08-27 22:20:37.030518952 +0000
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
-
- from mosq_test_helper import *
-
---- mosquitto-1.6.4/test/broker/09-extended-auth-single.py.old 2019-08-01 19:50:01.000000000 +0000
-+++ mosquitto-1.6.4/test/broker/09-extended-auth-single.py 2019-08-27 22:21:42.250519412 +0000
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
-
- # Multi tests for extended auth with a single step.
- # * Error in plugin
---- mosquitto-1.6.4/test/broker/09-extended-auth-single2.py.old 2019-08-01 19:50:01.000000000 +0000
-+++ mosquitto-1.6.4/test/broker/09-extended-auth-single2.py 2019-08-27 22:21:02.220519130 +0000
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
-
- # Multi tests for extended auth with a single step - multiple plugins at once.
- # * Error in plugin
---- mosquitto-1.6.4/test/broker/09-extended-auth-unsupported.py.old 2019-08-01 19:50:01.000000000 +0000
-+++ mosquitto-1.6.4/test/broker/09-extended-auth-unsupported.py 2019-08-27 22:21:20.360519257 +0000
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
-
- # Test whether an unsupported extended auth is rejected.
-