summaryrefslogtreecommitdiff
path: root/user/mosquitto
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2022-11-22 01:24:48 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2022-11-22 03:14:30 -0600
commitc0dc096a57d34804b09e360e6cadd0513d4401da (patch)
tree23c81609a7f25a67b62e8db5aeab7b2d372cf40e /user/mosquitto
parent0626331d80705ba36803ec0fb3062bd4355d9cd9 (diff)
downloadpackages-c0dc096a57d34804b09e360e6cadd0513d4401da.tar.gz
packages-c0dc096a57d34804b09e360e6cadd0513d4401da.tar.bz2
packages-c0dc096a57d34804b09e360e6cadd0513d4401da.tar.xz
packages-c0dc096a57d34804b09e360e6cadd0513d4401da.zip
user/mosquitto: Update to 2.0.15, clear some tests
Disable a few tests that fail on 32-bit systems. Closes: #851
Diffstat (limited to 'user/mosquitto')
-rw-r--r--user/mosquitto/APKBUILD15
-rw-r--r--user/mosquitto/no-persist_read_test.patch15
2 files changed, 26 insertions, 4 deletions
diff --git a/user/mosquitto/APKBUILD b/user/mosquitto/APKBUILD
index 3848992b8..4b7f6f06b 100644
--- a/user/mosquitto/APKBUILD
+++ b/user/mosquitto/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=mosquitto
-pkgver=2.0.14
+pkgver=2.0.15
pkgrel=0
pkgdesc="An Open Source MQTT Broker"
url="https://mosquitto.org/"
@@ -18,6 +18,7 @@ source="http://mosquitto.org/files/source/$pkgname-$pkgver.tar.gz
mosquitto.initd
openrc-conf.patch
endian.patch
+ no-persist_read_test.patch
"
# secfixes:
@@ -48,10 +49,14 @@ build() {
check() {
# Explicitly disable tests, instead of enabling only good ones.
# 08-ssl-connect-cert-auth-without-py: #687
+ # 06-bridge-reconnect-local-out.py:
+ # https://www.eclipse.org/lists/mosquitto-dev/msg02687.html
+ # (fix commit is not easily backported due to other churn)
# Other two: https://github.com/eclipse/mosquitto/issues/2550
sed -i test/broker/test.py \
-e '/08-ssl-connect-cert-auth-without.py/d' \
-e '/06-bridge-b2br-late-connection-retain.py/d' \
+ -e '/06-bridge-reconnect-local-out.py/d' \
-e '/11-pub-props.py/d' \
;
sed -i test/lib/test.py \
@@ -60,7 +65,8 @@ check() {
sed -i test/client/Makefile \
-e '/test.sh/d' \
;
- make ptest
+ # -j1 to avoid TLS errors on at least pmmx due to race.
+ make -j1 ptest
}
package() {
@@ -85,7 +91,8 @@ clients() {
mv "$pkgdir"/usr/bin/mosquitto_[ps]ub "$subpkgdir"/usr/bin/
}
-sha512sums="a9e4f41b9af679b30318570e86a465546024651373df10e3b132f4593b89d22d0dbac01bb7371a57132ba030a2e73971c612acb5c9ac12f5ccd06aa38d9444c2 mosquitto-2.0.14.tar.gz
+sha512sums="8a0c58222ea0b9304e7f096f6d13965478072baf1d1c9bc931b32a33f5ea8196c2dd54bde8d83fec7ed9cd413cb5fb115ce0a6701ca20664df52fdd7ca63ddaf mosquitto-2.0.15.tar.gz
681fddc737b3ef3e6c052f0c854a730df290352640a18a63e23ef83d14c425558aff87805d1eb95e44de101b5df48872173af9f5414464ffa8cf727ea2c0491e mosquitto.initd
b07f9bec2751ab32c43f53e74d8fca18dbf2d7ce7f8fab562dbcf75de19609ba6219d735ac504697404e0ed36613a14074e3a19e735297195877798f778d337a openrc-conf.patch
-89f738f77732500bc2aff3086b891c1e537510e756baf0ac92c1462c2ef7e47cdc62536d90174e6b6c80637199e463609723f9915999c0b95ce878ebbed739a1 endian.patch"
+89f738f77732500bc2aff3086b891c1e537510e756baf0ac92c1462c2ef7e47cdc62536d90174e6b6c80637199e463609723f9915999c0b95ce878ebbed739a1 endian.patch
+b173f11e898bf2d882b7d833f99c863dc1fd14ee6f55484c29dafd067fa1af27ab85864df674c0a042547c5c132b80123d159f10e7bdab316a0292461b91fafd no-persist_read_test.patch"
diff --git a/user/mosquitto/no-persist_read_test.patch b/user/mosquitto/no-persist_read_test.patch
new file mode 100644
index 000000000..6227e0487
--- /dev/null
+++ b/user/mosquitto/no-persist_read_test.patch
@@ -0,0 +1,15 @@
+This doesn't pass on 32-bit platforms as noted upstream at:
+https://github.com/eclipse/mosquitto/issues/2550
+
+We disable these tests for now.
+
+--- mosquitto-2.0.14/test/unit/Makefile.old 2021-11-16 18:28:35.000000000 -0600
++++ mosquitto-2.0.14/test/unit/Makefile 2022-11-22 00:37:32.237485238 -0600
+@@ -174,7 +174,5 @@
+
+ test-broker : build
+ ./bridge_topic_test
+- ./persist_read_test
+- ./persist_write_test
+ ./subs_test
+