summaryrefslogtreecommitdiff
path: root/user/ntfs-3g
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2018-09-21 18:33:02 -0400
committerMax Rees <maxcrees@me.com>2018-09-21 18:33:02 -0400
commit9c89fba736f2dca43867ae5ec0aeb27c75dbfb12 (patch)
tree3f70f57b9193e7fe49311596f02e89dd3cbd61f1 /user/ntfs-3g
parentc5bf59f31f3f4c600b2df990043a1eca21d57269 (diff)
downloadpackages-9c89fba736f2dca43867ae5ec0aeb27c75dbfb12.tar.gz
packages-9c89fba736f2dca43867ae5ec0aeb27c75dbfb12.tar.bz2
packages-9c89fba736f2dca43867ae5ec0aeb27c75dbfb12.tar.xz
packages-9c89fba736f2dca43867ae5ec0aeb27c75dbfb12.zip
user/ntfs-3g: new package
Diffstat (limited to 'user/ntfs-3g')
-rw-r--r--user/ntfs-3g/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/user/ntfs-3g/APKBUILD b/user/ntfs-3g/APKBUILD
new file mode 100644
index 000000000..d403c4f42
--- /dev/null
+++ b/user/ntfs-3g/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Valery Kartel <valery.kartel@gmail.com>
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Max Rees <maxcrees@me.com>
+pkgname=ntfs-3g
+_pkgname=ntfs-3g_ntfsprogs
+pkgver=2017.3.23
+pkgrel=1
+pkgdesc="Stable, full-featured, read-write NTFS"
+url="https://www.tuxera.com/community/open-source-ntfs-3g/"
+arch="all"
+options="!check" # No test suite.
+license="LGPL-2.1-only AND BSD-2-Clause AND GPL-2.0+ AND GPL-3.0+"
+makedepends="attr-dev util-linux-dev linux-headers fuse-dev"
+subpackages="$pkgname-doc $pkgname-dev $pkgname-libs"
+source="https://tuxera.com/opensource/$_pkgname-$pkgver.tgz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --with-fuse=external
+ make
+}
+
+package() {
+ cd "$builddir"
+ mkdir -p "$pkgdir"/lib
+ make -j1 DESTDIR="$pkgdir" LDCONFIG=: install
+ ln -s /bin/ntfs-3g "$pkgdir"/sbin/mount.ntfs
+}
+
+sha512sums="3a607f0d7be35204c992d8931de0404fbc52032c13b4240d2c5e6f285c318a28eb2a385d7cf5ac4cd445876aee5baa5753bb636ada0d870d84a9d3fdbce794ef ntfs-3g_ntfsprogs-2017.3.23.tgz"