summaryrefslogtreecommitdiff
path: root/user/orage
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-03-21 18:07:09 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-03-21 18:07:09 +0000
commitd7f18ab5ea69b1925f32ddf41ca9521d7fa996c6 (patch)
tree5308c32275e066f6e493b51fb34bd1d6715fb6c1 /user/orage
parent0bda41e070890d794799329cd9494ae0c4f24df7 (diff)
downloadpackages-d7f18ab5ea69b1925f32ddf41ca9521d7fa996c6.tar.gz
packages-d7f18ab5ea69b1925f32ddf41ca9521d7fa996c6.tar.bz2
packages-d7f18ab5ea69b1925f32ddf41ca9521d7fa996c6.tar.xz
packages-d7f18ab5ea69b1925f32ddf41ca9521d7fa996c6.zip
user/orage: fix build with libical 3
Diffstat (limited to 'user/orage')
-rw-r--r--user/orage/APKBUILD9
-rw-r--r--user/orage/libical-3.patch76
2 files changed, 82 insertions, 3 deletions
diff --git a/user/orage/APKBUILD b/user/orage/APKBUILD
index 48f5ef945..4cb9121e2 100644
--- a/user/orage/APKBUILD
+++ b/user/orage/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
pkgname=orage
pkgver=4.12.1
-pkgrel=0
+pkgrel=1
pkgdesc="Calendaring software for the XFCE desktop environment"
url="https://xfce.org"
arch="all"
@@ -11,7 +11,9 @@ makedepends="intltool gtk+2.0-dev dbus-glib-dev libnotify-dev popt-dev
xfce4-panel-dev"
subpackages="$pkgname-doc $pkgname-lang"
langdir="/usr/lib/locale"
-source="http://archive.xfce.org/src/apps/orage/4.12/orage-$pkgver.tar.bz2"
+source="http://archive.xfce.org/src/apps/orage/4.12/orage-$pkgver.tar.bz2
+ libical-3.patch
+ "
build() {
cd "$builddir"
@@ -35,4 +37,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="3fec0201171140586cdc9bcf151450a7086515e18b5815afe4fe4c4726ba554c50582b0479e52985b330140c51b7233ef81f678f986f848afbeee74c66b2d196 orage-4.12.1.tar.bz2"
+sha512sums="3fec0201171140586cdc9bcf151450a7086515e18b5815afe4fe4c4726ba554c50582b0479e52985b330140c51b7233ef81f678f986f848afbeee74c66b2d196 orage-4.12.1.tar.bz2
+4f46c99ee3354861d2dca34b9a87bdacc8cd9ad0ad935a364b45b850c08b461c32550bb4df185b66c3963c12f8171ba700c46c263baf92ded8eabc2476bb8cc0 libical-3.patch"
diff --git a/user/orage/libical-3.patch b/user/orage/libical-3.patch
new file mode 100644
index 000000000..ad57fd3cb
--- /dev/null
+++ b/user/orage/libical-3.patch
@@ -0,0 +1,76 @@
+From 58e4bb4d3b982876dec33d55003d591559439598 Mon Sep 17 00:00:00 2001
+From: Stefan Seyfried <seife+dev@b1-systems.com>
+Date: Sat, 3 Mar 2018 20:25:24 +0100
+Subject: [PATCH] fix build with libical version 3
+
+---
+ src/ical-code.c | 12 ++++++++++++
+ 1 file changed, 12 insertions(+)
+
+diff --git a/src/ical-code.c b/src/ical-code.c
+index d5831404..c40042c3 100644
+--- a/src/ical-code.c
++++ b/src/ical-code.c
+@@ -2579,7 +2579,9 @@ static struct icaltimetype count_first_alarm_time(xfical_period per
+ * when counting alarm time. */
+ if (rel == ICAL_RELATED_START) {
+ per.stime.is_date = 0;
++#if ICAL_MAJOR_VERSION < 3
+ per.stime.is_utc = 1;
++#endif
+ per.stime.is_daylight = 0;
+ per.stime.zone = utc_icaltimezone;
+ per.stime.hour = 0;
+@@ -2588,7 +2590,9 @@ static struct icaltimetype count_first_alarm_time(xfical_period per
+ }
+ else {
+ per.etime.is_date = 0;
++#if ICAL_MAJOR_VERSION < 3
+ per.etime.is_utc = 1;
++#endif
+ per.etime.is_daylight = 0;
+ per.etime.zone = utc_icaltimezone;
+ per.etime.hour = 0;
+@@ -2613,7 +2617,9 @@ static struct icaltimetype count_next_alarm_time(struct icaltimetype start_time
+ /* HACK: convert to UTC time so that we can use time arithmetic
+ * when counting alarm time. */
+ start_time.is_date = 0;
++#if ICAL_MAJOR_VERSION < 3
+ start_time.is_utc = 1;
++#endif
+ start_time.is_daylight = 0;
+ start_time.zone = utc_icaltimezone;
+ start_time.hour = 0;
+@@ -2768,7 +2774,9 @@ static alarm_struct *process_alarm_trigger(icalcomponent *c
+ */
+ if (icaltime_is_date(per.stime)) {
+ if (local_icaltimezone != utc_icaltimezone) {
++#if ICAL_MAJOR_VERSION < 3
+ next_alarm_time.is_utc = 0;
++#endif
+ next_alarm_time.is_daylight = 0;
+ next_alarm_time.zone = local_icaltimezone;
+ }
+@@ -2850,7 +2858,9 @@ orage_message(120, P_N "Alarm rec loop next_start:%s next_alarm:%s per.stime:%s"
+ */
+ if (icaltime_is_date(per.stime)) {
+ if (local_icaltimezone != utc_icaltimezone) {
++#if ICAL_MAJOR_VERSION < 3
+ next_alarm_time.is_utc = 0;
++#endif
+ next_alarm_time.is_daylight = 0;
+ next_alarm_time.zone = local_icaltimezone;
+ }
+@@ -2944,7 +2954,9 @@ orage_message(120, P_N "*****After loop Alarm %s %s", icaltime_as_ical_string(ne
+ */
+ if (icaltime_is_date(per.stime)) {
+ if (local_icaltimezone != utc_icaltimezone) {
++#if ICAL_MAJOR_VERSION < 3
+ next_alarm_time.is_utc = 0;
++#endif
+ next_alarm_time.is_daylight = 0;
+ next_alarm_time.zone = local_icaltimezone;
+ }
+--
+2.16.2
+