summaryrefslogtreecommitdiff
path: root/user/os-prober
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-10-14 14:13:26 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-10-14 14:13:26 +0000
commitb5b897e47ab11998c46db7f9ba96410a187c0634 (patch)
tree3833d143daed3db446b395834be310a036e5b08b /user/os-prober
parent0953fc198e1ba6935baf53038d971289b4f9b634 (diff)
downloadpackages-b5b897e47ab11998c46db7f9ba96410a187c0634.tar.gz
packages-b5b897e47ab11998c46db7f9ba96410a187c0634.tar.bz2
packages-b5b897e47ab11998c46db7f9ba96410a187c0634.tar.xz
packages-b5b897e47ab11998c46db7f9ba96410a187c0634.zip
user/os-prober: new package
Diffstat (limited to 'user/os-prober')
-rw-r--r--user/os-prober/APKBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/user/os-prober/APKBUILD b/user/os-prober/APKBUILD
new file mode 100644
index 000000000..65ff5061b
--- /dev/null
+++ b/user/os-prober/APKBUILD
@@ -0,0 +1,50 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=os-prober
+pkgver=1.77
+pkgrel=0
+pkgdesc="Utility to detect operating systems on hard drives"
+url="http://joeyh.name/code/os-prober/"
+arch="all"
+options="!check" # No test suite.
+license="GPL-2.0+ AND GPL-1.0+"
+depends="/bin/sh"
+makedepends=""
+subpackages=""
+source="http://deb.debian.org/debian/pool/main/o/os-prober/os-prober_$pkgver.tar.xz"
+
+build() {
+ make
+}
+
+package() {
+ case $CTARGET_ARCH in
+ i486|i586|pmmx|x86*)
+ PROBE_ARCH=x86;;
+ ppc*)
+ PROBE_ARCH=powerpc;;
+ sparc*)
+ PROBE_ARCH=sparc;;
+ *)
+ PROBE_ARCH=$CTARGET_ARCH;;
+ esac
+ for probes in os-probes os-probes/mounted os-probes/init \
+ linux-boot-probes linux-boot-probes/mounted; do
+ mkdir -p "$pkgdir/usr/lib/$probes"
+ for file in $probes/common/*; do
+ install -Dm644 $file "$pkgdir/usr/lib/$probes"
+ done
+ if [ -e "$probes/${PROBE_ARCH}" ]; then
+ install -Dm644 $probes/${PROBE_ARCH}/* \
+ "$pkgdir/usr/lib/$probes"
+ fi
+ done
+ mkdir -p "$pkgdir"/usr/lib/os-prober "$pkgdir"/usr/bin
+ mkdir -p "$pkgdir"/usr/share/os-prober
+ install -Dm755 newns "$pkgdir"/usr/lib/os-prober/
+ install -Dm755 os-prober "$pkgdir"/usr/bin/
+ install -Dm755 linux-boot-prober "$pkgdir"/usr/bin/
+ install -Dm644 common.sh "$pkgdir"/usr/share/os-prober/
+}
+
+sha512sums="4d9c22ccc4d950644a06a17ec4424aca5ff82aeb20052dc389dd451b6b9a1799c5a9438644a29093153730af42066abbbbb78f593f2564314c9adbd43f60e39b os-prober_1.77.tar.xz"