summaryrefslogtreecommitdiff
path: root/user/oxygen-fonts/APKBUILD
diff options
context:
space:
mode:
authorCyberLeo <cyberleo@cyberleo.net>2020-03-28 05:45:52 -0500
committerCyberLeo <cyberleo@cyberleo.net>2020-03-28 05:45:52 -0500
commit9297468fa579836e3a6a381b798feb6b78217c2d (patch)
tree53168212f427afbcf0693b534530a4af803152e9 /user/oxygen-fonts/APKBUILD
parenta63cc05c53a6f4c22422dc8c69808b14d87a6f6e (diff)
parentda5a69b65a8791fffa6e93366ee585f87eff136d (diff)
downloadpackages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.gz
packages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.bz2
packages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.xz
packages-9297468fa579836e3a6a381b798feb6b78217c2d.zip
Merge branch 'master' into zfs
Diffstat (limited to 'user/oxygen-fonts/APKBUILD')
-rw-r--r--user/oxygen-fonts/APKBUILD7
1 files changed, 2 insertions, 5 deletions
diff --git a/user/oxygen-fonts/APKBUILD b/user/oxygen-fonts/APKBUILD
index 152a0aae4..bf4202efb 100644
--- a/user/oxygen-fonts/APKBUILD
+++ b/user/oxygen-fonts/APKBUILD
@@ -10,10 +10,9 @@ license="OFL-1.1"
depends=""
makedepends="cmake extra-cmake-modules qt5-qtbase-dev fontforge-dev"
subpackages=""
-source="http://download.kde.org/stable/plasma/$pkgver/oxygen-fonts-$pkgver.tar.xz"
+source="https://download.kde.org/stable/plasma/$pkgver/oxygen-fonts-$pkgver.tar.xz"
build() {
- cd "$builddir"
if [ "$CBUILD" != "$CHOST" ]; then
CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
@@ -24,17 +23,15 @@ build() {
-DCMAKE_BUILD_TYPE=RelWithDebugInfo \
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
-DCMAKE_C_FLAGS="$CFLAGS" \
- ${CMAKE_CROSSOPTS}
+ ${CMAKE_CROSSOPTS} .
make
}
check() {
- cd "$builddir"
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}