summaryrefslogtreecommitdiff
path: root/user/oxygen-icons5/APKBUILD
diff options
context:
space:
mode:
authorCyberLeo <cyberleo@cyberleo.net>2020-03-28 05:45:52 -0500
committerCyberLeo <cyberleo@cyberleo.net>2020-03-28 05:45:52 -0500
commit9297468fa579836e3a6a381b798feb6b78217c2d (patch)
tree53168212f427afbcf0693b534530a4af803152e9 /user/oxygen-icons5/APKBUILD
parenta63cc05c53a6f4c22422dc8c69808b14d87a6f6e (diff)
parentda5a69b65a8791fffa6e93366ee585f87eff136d (diff)
downloadpackages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.gz
packages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.bz2
packages-9297468fa579836e3a6a381b798feb6b78217c2d.tar.xz
packages-9297468fa579836e3a6a381b798feb6b78217c2d.zip
Merge branch 'master' into zfs
Diffstat (limited to 'user/oxygen-icons5/APKBUILD')
-rw-r--r--user/oxygen-icons5/APKBUILD9
1 files changed, 3 insertions, 6 deletions
diff --git a/user/oxygen-icons5/APKBUILD b/user/oxygen-icons5/APKBUILD
index 6c44d063b..397e87ce7 100644
--- a/user/oxygen-icons5/APKBUILD
+++ b/user/oxygen-icons5/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=oxygen-icons5
-pkgver=5.54.0
+pkgver=5.68.0
pkgrel=0
pkgdesc="The KDE Oxygen icon set"
url="https://www.kde.org/"
@@ -14,7 +14,6 @@ subpackages=""
source="https://download.kde.org/stable/frameworks/${pkgver%.*}/oxygen-icons5-$pkgver.tar.xz"
build() {
- cd "$builddir"
if [ "$CBUILD" != "$CHOST" ]; then
CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
@@ -25,18 +24,16 @@ build() {
-DCMAKE_BUILD_TYPE=RelWithDebugInfo \
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
-DCMAKE_C_FLAGS="$CFLAGS" \
- ${CMAKE_CROSSOPTS}
+ ${CMAKE_CROSSOPTS} .
make
}
check() {
- cd "$builddir"
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="5ae34015aebff31cab3192905c388ac5a75c67e7b24ba3bb12075edf6f6cb013f9ace837ea8dd4ef7c5174e27ea1b84e418b34eb983648943c4063dd076d6ccb oxygen-icons5-5.54.0.tar.xz"
+sha512sums="d7ba6906823b0e4c6a724b98b587808d8136e29a7f3bdf6fdb8309cbb9bfd43bc903a79cf5629c5f5cbf15510de3526332728f538d8ff624c52c021488b4ca6c oxygen-icons5-5.68.0.tar.xz"