summaryrefslogtreecommitdiff
path: root/user/pcmanfm-qt
diff options
context:
space:
mode:
authorKiyoshi Aman <kiyoshi.aman+adelie@gmail.com>2017-10-12 20:54:36 +0000
committerKiyoshi Aman <kiyoshi.aman+adelie@gmail.com>2017-10-12 20:54:36 +0000
commitc75e4e0576fa24557efa0ef018646bf3dc51019b (patch)
tree5a9ea38db9e1640b53666b3b5e11f742b562b0be /user/pcmanfm-qt
parentf2e73738e51fd71115eef26ebaf6adc12fe99548 (diff)
downloadpackages-c75e4e0576fa24557efa0ef018646bf3dc51019b.tar.gz
packages-c75e4e0576fa24557efa0ef018646bf3dc51019b.tar.bz2
packages-c75e4e0576fa24557efa0ef018646bf3dc51019b.tar.xz
packages-c75e4e0576fa24557efa0ef018646bf3dc51019b.zip
user/pcmanfm-qt: new package
Diffstat (limited to 'user/pcmanfm-qt')
-rw-r--r--user/pcmanfm-qt/APKBUILD49
-rw-r--r--user/pcmanfm-qt/pcmanfm-qt-0.11.3-const-iterator-fixes.patch26
2 files changed, 75 insertions, 0 deletions
diff --git a/user/pcmanfm-qt/APKBUILD b/user/pcmanfm-qt/APKBUILD
new file mode 100644
index 000000000..616be857a
--- /dev/null
+++ b/user/pcmanfm-qt/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman+adelie@gmail.com>
+pkgname=pcmanfm-qt
+pkgver=0.11.3
+pkgrel=0
+pkgdesc="File manager and desktop icon manager for LXQt"
+url="http://lxqt.org"
+arch="all"
+license="GPL-2.0+"
+depends=""
+depends_dev=""
+makedepends="cmake extra-cmake-modules lxqt-build-tools libfm-qt-dev liblxqt-dev qt5-qtx11extras-dev qt5-qttools-dev kwindowsystem-dev $depends_dev"
+install=""
+subpackages="$pkgname-doc"
+source="https://github.com/lxde/pcmanfm-qt/releases/download/$pkgver/pcmanfm-qt-$pkgver.tar.xz
+ pcmanfm-qt-0.11.3-const-iterator-fixes.patch"
+builddir="$srcdir/pcmanfm-qt-$pkgver"
+# no tests
+options="!check"
+
+build() {
+ cd "$builddir"
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ -DCMAKE_BUILD_TYPE=RelWithDebugInfo \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
+ -DCMAKE_C_FLAGS="$CFLAGS" \
+ -DPULL_TRANSLATIONS=False \
+ ${CMAKE_CROSSOPTS}
+ make
+}
+
+check() {
+ cd "$builddir"
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="168012e022da30d4c2821e34f47372fae421b8b400cc3b2b0c16046f31bbdcb08814d0dd2ea2f0b615fafee4ac8af53ffa5fc0ceb170ccaa29468eec8b30de6d pcmanfm-qt-0.11.3.tar.xz
+127eca77c12c2b32b6106ae71b306d8d5fd85d8a2a3c25742f230054cfd7940f43f8d7dda5cc8009cae12a46adb62a6037af9dea0bb00b36b680d249b9e3278c pcmanfm-qt-0.11.3-const-iterator-fixes.patch"
diff --git a/user/pcmanfm-qt/pcmanfm-qt-0.11.3-const-iterator-fixes.patch b/user/pcmanfm-qt/pcmanfm-qt-0.11.3-const-iterator-fixes.patch
new file mode 100644
index 000000000..b52ce1a9f
--- /dev/null
+++ b/user/pcmanfm-qt/pcmanfm-qt-0.11.3-const-iterator-fixes.patch
@@ -0,0 +1,26 @@
+diff -Nurd pcmanfm-qt-0.11.3/pcmanfm/mainwindow.cpp pcmanfm-qt-0.11.3.new/pcmanfm/mainwindow.cpp
+--- pcmanfm-qt-0.11.3/pcmanfm/mainwindow.cpp 2017-01-14 02:13:45.000000000 +0000
++++ pcmanfm-qt-0.11.3.new/pcmanfm/mainwindow.cpp 2017-10-12 20:44:25.731044585 +0000
+@@ -970,8 +970,8 @@
+ void MainWindow::onBookmarksChanged(FmBookmarks* bookmarks, MainWindow* pThis) {
+ // delete existing items
+ QList<QAction*> actions = pThis->ui.menu_Bookmarks->actions();
+- QList<QAction*>::const_iterator it = actions.begin();
+- QList<QAction*>::const_iterator last_it = actions.end() - 2;
++ QList<QAction*>::const_iterator it = actions.constBegin();
++ QList<QAction*>::const_iterator last_it = actions.constEnd() - 2;
+
+ while(it != last_it) {
+ QAction* action = *it;
+diff -Nurd pcmanfm-qt-0.11.3/pcmanfm/preferencesdialog.cpp pcmanfm-qt-0.11.3.new/pcmanfm/preferencesdialog.cpp
+--- pcmanfm-qt-0.11.3/pcmanfm/preferencesdialog.cpp 2017-01-14 02:13:45.000000000 +0000
++++ pcmanfm-qt-0.11.3.new/pcmanfm/preferencesdialog.cpp 2017-10-12 20:45:17.324377059 +0000
+@@ -90,7 +90,7 @@
+
+ iconThemes.remove("hicolor"); // remove hicolor, which is only a fallback
+ QHash<QString, QString>::const_iterator it;
+- for(it = iconThemes.begin(); it != iconThemes.end(); ++it) {
++ for(it = iconThemes.constBegin(); it != iconThemes.constEnd(); ++it) {
+ ui.iconTheme->addItem(it.value(), it.key());
+ }
+ ui.iconTheme->model()->sort(0); // sort the list of icon theme names