summaryrefslogtreecommitdiff
path: root/user/pcmciautils
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-27 03:28:52 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-07-27 03:28:52 -0500
commit8b1c1ddc81ad85a42affffce785fb80d237feec0 (patch)
tree14208c3bb9d7af37ab87fe6d6a4f59897edc584f /user/pcmciautils
parent0b742ec3f1217699497b23ec293ac0f2007a4042 (diff)
downloadpackages-8b1c1ddc81ad85a42affffce785fb80d237feec0.tar.gz
packages-8b1c1ddc81ad85a42affffce785fb80d237feec0.tar.bz2
packages-8b1c1ddc81ad85a42affffce785fb80d237feec0.tar.xz
packages-8b1c1ddc81ad85a42affffce785fb80d237feec0.zip
user/pcmciautils: actually use upstream tarball
Diffstat (limited to 'user/pcmciautils')
-rw-r--r--user/pcmciautils/APKBUILD31
-rw-r--r--user/pcmciautils/disable_yywrap.patch27
-rw-r--r--user/pcmciautils/unsigned.patch22
3 files changed, 80 insertions, 0 deletions
diff --git a/user/pcmciautils/APKBUILD b/user/pcmciautils/APKBUILD
new file mode 100644
index 000000000..f94d49086
--- /dev/null
+++ b/user/pcmciautils/APKBUILD
@@ -0,0 +1,31 @@
+# Maintainer:
+pkgname=pcmciautils
+pkgver=018
+pkgrel=2
+pkgdesc="Utilities for inserting and removing PCMCIA cards"
+url="https://kernel.org/pub/linux/utils/kernel/pcmcia/"
+arch="all"
+options="!check" # No test suite.
+license="GPL-2.0-only"
+depends=""
+makedepends="bison flex sysfsutils-dev"
+subpackages="$pkgname-doc"
+source="https://mirrors.kernel.org/pub/linux/utils/kernel/pcmcia/$pkgname-$pkgver.tar.xz
+ unsigned.patch
+ disable_yywrap.patch
+ "
+
+build() {
+ cd "$builddir"
+ make -j1 LEX=flex
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir"/ install
+ ln -sf pccardctl "$pkgdir"/sbin/lspcmcia
+}
+
+sha512sums="69a01cb4d6cefc4bcb31309fafbd76f937dd0599fbd097a5f22d76d3bc4eeddfccd16bddf42d8e079b323bd8eb62f4b0b25e1da3755664bd01cb2ccbf939c7cf pcmciautils-018.tar.xz
+18e5d3bfe3316c49e4a899b9181177c1c275274d5788a4af7299d0c6b8cbdfca8f3465f242356d35c6e96103cb620173e6f93e7e66787d5d2b194c5a4264bf91 unsigned.patch
+b96f9bc3176f1eeb936a31f8fab5a495ce14218e92fbae2350aa970328b53bd6732ade90721f1ca55d80a94436189773f83a300aa8af7c43ecc5ed62c95f3557 disable_yywrap.patch"
diff --git a/user/pcmciautils/disable_yywrap.patch b/user/pcmciautils/disable_yywrap.patch
new file mode 100644
index 000000000..e30abb0d1
--- /dev/null
+++ b/user/pcmciautils/disable_yywrap.patch
@@ -0,0 +1,27 @@
+--- pcmciautils-018/src/lex_config.l
++++ pcmciautils-018/src/lex_config.l
+@@ -1,8 +1,8 @@
+ /* Special state for handling include files */
+ %x src
+-%option noinput nounput
++%option noinput nounput noyywrap
+
+ %{
+ /*
+ * Startup tool for non statically mapped PCMCIA sockets
+ *
+@@ -75,14 +75,10 @@ module /* skip */ ;
+
+ . return yytext[0];
+
+ %%
+
+-#ifndef yywrap
+-int yywrap() { return 1; }
+-#endif
+-
+ /*======================================================================
+
+ Stuff to parse basic data types
+
+ ======================================================================*/
diff --git a/user/pcmciautils/unsigned.patch b/user/pcmciautils/unsigned.patch
new file mode 100644
index 000000000..8781068f8
--- /dev/null
+++ b/user/pcmciautils/unsigned.patch
@@ -0,0 +1,22 @@
+--- pcmciautils-018/src/read-cis.c.orig 2014-11-06 10:07:20.363207536 +0600
++++ pcmciautils-018/src/read-cis.c 2014-11-06 10:08:37.143611772 +0600
+@@ -51,7 +51,7 @@
+ /* Get indirect link from the MFC tuple */
+ read_cis(tuple->Flags.link_space,
+ tuple->LinkOffset, 5, link);
+- ofs = *(u_int *)(link+1);
++ ofs = *(unsigned int *)(link+1);
+ tuple->Flags.space = (link[0] == CISTPL_MFC_ATTR);
+ /* Move to the next indirect link */
+ tuple->LinkOffset += 5;
+--- pcmciautils-018/src/yacc_config.y.orig 2014-11-06 10:08:55.857046934 +0600
++++ pcmciautils-018/src/yacc_config.y 2014-11-06 10:09:10.543788999 +0600
+@@ -40,7 +40,7 @@
+
+ %union {
+ char *str;
+- u_long num;
++ unsigned long num;
+ struct adjust_list_t *adjust;
+ }
+