summaryrefslogtreecommitdiff
path: root/user/perl-apache-logformat-compiler
diff options
context:
space:
mode:
authorKiyoshi Aman <kiyoshi.aman+adelie@gmail.com>2019-10-17 18:44:40 -0400
committerKiyoshi Aman <kiyoshi.aman+adelie@gmail.com>2019-10-17 18:44:40 -0400
commitb163eb1b88e25226d5a45816367522bffac0a978 (patch)
tree7cc5851d783856d9199aa6b90d51790b7af38de8 /user/perl-apache-logformat-compiler
parent8afb6ffbf97bc59a6b97d110bf88c9357be5ad83 (diff)
downloadpackages-b163eb1b88e25226d5a45816367522bffac0a978.tar.gz
packages-b163eb1b88e25226d5a45816367522bffac0a978.tar.bz2
packages-b163eb1b88e25226d5a45816367522bffac0a978.tar.xz
packages-b163eb1b88e25226d5a45816367522bffac0a978.zip
user/perl-*: modernise
Diffstat (limited to 'user/perl-apache-logformat-compiler')
-rw-r--r--user/perl-apache-logformat-compiler/APKBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/user/perl-apache-logformat-compiler/APKBUILD b/user/perl-apache-logformat-compiler/APKBUILD
index 5acc4ffbc..cd8d5aa99 100644
--- a/user/perl-apache-logformat-compiler/APKBUILD
+++ b/user/perl-apache-logformat-compiler/APKBUILD
@@ -1,7 +1,10 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-apache-logformat-compiler
-_pkgname=Apache-LogFormat-Compiler
+_pkgreal=Apache-LogFormat-Compiler
+_author=KAZEBURO
+_au=${_author%%"${_author#??}"}
+_a=${_author%%"${_author#?}"}
pkgver=0.35
pkgrel=0
pkgdesc="Compile a log format string to Perl code"
@@ -12,22 +15,19 @@ depends="perl-posix-strftime-compiler perl-try-tiny"
checkdepends="perl-http-message perl-test-mocktime"
makedepends="perl-dev perl-module-build-tiny"
subpackages="$pkgname-doc"
-source="https://cpan.metacpan.org/authors/id/K/KA/KAZEBURO/Apache-LogFormat-Compiler-$pkgver.tar.gz"
-builddir="$srcdir/Apache-LogFormat-Compiler-$pkgver"
+source="https://cpan.metacpan.org/authors/id/$_a/$_au/$_author/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
build() {
- cd "$builddir"
perl Build.PL --destdir="$pkgdir" --prefix="/usr" --installdirs=vendor
./Build
}
check() {
- cd "$builddir"
./Build test
}
package() {
- cd "$builddir"
./Build install destdir="$pkgdir"
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}