summaryrefslogtreecommitdiff
path: root/user/perl-extutils-parsexs
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2020-02-16 21:13:53 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2020-02-16 21:13:53 +0000
commitdbbc5072f5c2b428de142604b9c1c70b4159a845 (patch)
treea3956d8d7cc74f020d042e34eb808a49ac4860c9 /user/perl-extutils-parsexs
parent9d8715562c846a78b9679d405d136e05a2fa330f (diff)
parentca5ed52ede018f31ebfd896d367f589675e62b7e (diff)
downloadpackages-dbbc5072f5c2b428de142604b9c1c70b4159a845.tar.gz
packages-dbbc5072f5c2b428de142604b9c1c70b4159a845.tar.bz2
packages-dbbc5072f5c2b428de142604b9c1c70b4159a845.tar.xz
packages-dbbc5072f5c2b428de142604b9c1c70b4159a845.zip
Merge branch 'bumps.aerdan.20200214' into 'master'
Bumps for packages owned by Kiyoshi Aman as of 15 Feb 2020 See merge request adelie/packages!400
Diffstat (limited to 'user/perl-extutils-parsexs')
-rw-r--r--user/perl-extutils-parsexs/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/user/perl-extutils-parsexs/APKBUILD b/user/perl-extutils-parsexs/APKBUILD
new file mode 100644
index 000000000..feb576d92
--- /dev/null
+++ b/user/perl-extutils-parsexs/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
+# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
+pkgname=perl-extutils-parsexs
+_pkgreal=ExtUtils-ParseXS
+_author=SMUELLER
+_au=${_author%%"${_author#??}"}
+_a=${_author%%"${_author#?}"}
+pkgver=3.35
+pkgrel=0
+pkgdesc="Perl module for converting XS code into C"
+url="https://metacpan.org/pod/ExtUtils::ParseXS"
+arch="all"
+license="Artistic-2.0 OR GPL-2.0-only"
+depends="perl"
+makedepends="perl-dev"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/$_a/$_au/$_author/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/ExtUtils-ParseXS-$pkgver"
+
+build() {
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ make test
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="90862ecb97f19066a4564be1788bd061c5835abb440fbea2cad43c903e912a7864453ef61c2c384566a4fe6536783f480938c4460b63879734a2d74372a956b8 ExtUtils-ParseXS-3.35.tar.gz"