summaryrefslogtreecommitdiff
path: root/user/perl-file-copy-recursive/APKBUILD
diff options
context:
space:
mode:
authorDan Theisen <djt@hxx.in>2018-09-26 01:07:05 -0700
committerDan Theisen <djt@hxx.in>2018-09-26 01:07:05 -0700
commit37206f14e542ab14fd94ec401884e89722cc7ae4 (patch)
tree2b843642b9107bce5f8a7942fee04e20401341a5 /user/perl-file-copy-recursive/APKBUILD
parentc3d3e9508f8640bafb126d334b5f24ff5dbd23bd (diff)
downloadpackages-37206f14e542ab14fd94ec401884e89722cc7ae4.tar.gz
packages-37206f14e542ab14fd94ec401884e89722cc7ae4.tar.bz2
packages-37206f14e542ab14fd94ec401884e89722cc7ae4.tar.xz
packages-37206f14e542ab14fd94ec401884e89722cc7ae4.zip
user/perl-file-copy-recursive: new package
Diffstat (limited to 'user/perl-file-copy-recursive/APKBUILD')
-rw-r--r--user/perl-file-copy-recursive/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/user/perl-file-copy-recursive/APKBUILD b/user/perl-file-copy-recursive/APKBUILD
new file mode 100644
index 000000000..882a25d2f
--- /dev/null
+++ b/user/perl-file-copy-recursive/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Dan Theisen <djt@hxx.in>
+# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
+pkgname=perl-file-copy-recursive
+pkgver=0.44
+pkgrel=0
+pkgdesc="Perl extension for recursively copying files and directories"
+url="https://metacpan.org/pod/File::Copy::Recursive"
+arch="noarch"
+license="Artistic-1.0-Perl AND GPL-2.0"
+depends="perl"
+makedepends="perl-dev"
+checkdepends="perl-test-fatal perl-test-warnings perl-path-tiny perl-test-deep perl-test-file"
+install=""
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/D/DM/DMUEY/File-Copy-Recursive-$pkgver.tar.gz"
+builddir="$srcdir/File-Copy-Recursive-$pkgver"
+
+build() {
+ cd "$builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="7599c48cee0b9848d5e275a1de00845cb2d4820eda9092d550063d4791974870129ce8d3d9337a8f7ea413ed4c21e533c2eb3134c2fcb5cc412dbbfddd2500e4 File-Copy-Recursive-0.44.tar.gz"