summaryrefslogtreecommitdiff
path: root/user/perl-filesys-notify-simple
diff options
context:
space:
mode:
authorKiyoshi Aman <kiyoshi.aman+adelie@gmail.com>2019-10-17 18:44:40 -0400
committerKiyoshi Aman <kiyoshi.aman+adelie@gmail.com>2019-10-17 18:44:40 -0400
commitb163eb1b88e25226d5a45816367522bffac0a978 (patch)
tree7cc5851d783856d9199aa6b90d51790b7af38de8 /user/perl-filesys-notify-simple
parent8afb6ffbf97bc59a6b97d110bf88c9357be5ad83 (diff)
downloadpackages-b163eb1b88e25226d5a45816367522bffac0a978.tar.gz
packages-b163eb1b88e25226d5a45816367522bffac0a978.tar.bz2
packages-b163eb1b88e25226d5a45816367522bffac0a978.tar.xz
packages-b163eb1b88e25226d5a45816367522bffac0a978.zip
user/perl-*: modernise
Diffstat (limited to 'user/perl-filesys-notify-simple')
-rw-r--r--user/perl-filesys-notify-simple/APKBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/user/perl-filesys-notify-simple/APKBUILD b/user/perl-filesys-notify-simple/APKBUILD
index 821374e2f..d87fcbb4b 100644
--- a/user/perl-filesys-notify-simple/APKBUILD
+++ b/user/perl-filesys-notify-simple/APKBUILD
@@ -1,33 +1,33 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-filesys-notify-simple
-_pkgname=Filesys-Notify-Simple
+_pkgreal=Filesys-Notify-Simple
+_author=MIYAGAWA
+_au=${_author%%"${_author#??}"}
+_a=${_author%%"${_author#?}"}
pkgver=0.13
pkgrel=0
pkgdesc="Simple file system watcher for Perl"
url="https://metacpan.org/release/Filesys-Notify-Simple"
arch="noarch"
license="Artistic-1.0-Perl OR GPL-2.0-only"
-depends=""
+depends="perl"
checkdepends="perl-test-sharedfork"
makedepends="perl-dev"
subpackages="$pkgname-doc"
-source="https://cpan.metacpan.org/authors/id/M/MI/MIYAGAWA/Filesys-Notify-Simple-$pkgver.tar.gz"
-builddir="$srcdir/Filesys-Notify-Simple-$pkgver"
+source="https://cpan.metacpan.org/authors/id/$_a/$_au/$_author/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
build() {
- cd "$builddir"
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd "$builddir"
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}