summaryrefslogtreecommitdiff
path: root/user/perl-hash-multivalue
diff options
context:
space:
mode:
authorKiyoshi Aman <kiyoshi.aman+adelie@gmail.com>2019-10-17 18:44:40 -0400
committerKiyoshi Aman <kiyoshi.aman+adelie@gmail.com>2019-10-17 18:44:40 -0400
commitb163eb1b88e25226d5a45816367522bffac0a978 (patch)
tree7cc5851d783856d9199aa6b90d51790b7af38de8 /user/perl-hash-multivalue
parent8afb6ffbf97bc59a6b97d110bf88c9357be5ad83 (diff)
downloadpackages-b163eb1b88e25226d5a45816367522bffac0a978.tar.gz
packages-b163eb1b88e25226d5a45816367522bffac0a978.tar.bz2
packages-b163eb1b88e25226d5a45816367522bffac0a978.tar.xz
packages-b163eb1b88e25226d5a45816367522bffac0a978.zip
user/perl-*: modernise
Diffstat (limited to 'user/perl-hash-multivalue')
-rw-r--r--user/perl-hash-multivalue/APKBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/user/perl-hash-multivalue/APKBUILD b/user/perl-hash-multivalue/APKBUILD
index c1fa7dac2..f034200c1 100644
--- a/user/perl-hash-multivalue/APKBUILD
+++ b/user/perl-hash-multivalue/APKBUILD
@@ -1,32 +1,32 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-hash-multivalue
-_pkgname=Hash-MultiValue
+_pkgreal=Hash-MultiValue
+_author=ARISTOTLE
+_au=${_author%%"${_author#??}"}
+_a=${_author%%"${_author#?}"}
pkgver=0.16
pkgrel=0
pkgdesc="Multi-hash implementation for Perl"
url="https://metacpan.org/release/Hash-MultiValue"
arch="noarch"
license="Artistic-1.0-Perl OR GPL-2.0-only"
-depends=""
-makedepends="perl-dev"
+depends="perl"
+makedepends=""
subpackages="$pkgname-doc"
-source="https://cpan.metacpan.org/authors/id/A/AR/ARISTOTLE/Hash-MultiValue-$pkgver.tar.gz"
-builddir="$srcdir/Hash-MultiValue-$pkgver"
+source="https://cpan.metacpan.org/authors/id/$_a/$_au/$_author/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
build() {
- cd "$builddir"
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd "$builddir"
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}