summaryrefslogtreecommitdiff
path: root/user/perl-html-formattext-withlinks
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-11-18 02:49:11 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-11-18 02:49:11 +0000
commit7f269e026da39a78af5158cc0fba1d7dff2cdf07 (patch)
tree8cfe70aa3156d15655e283998a0f9a56ce531877 /user/perl-html-formattext-withlinks
parentf3bd7b8c10c09348c72ad9f4ec2d25b4d3c05f5a (diff)
downloadpackages-7f269e026da39a78af5158cc0fba1d7dff2cdf07.tar.gz
packages-7f269e026da39a78af5158cc0fba1d7dff2cdf07.tar.bz2
packages-7f269e026da39a78af5158cc0fba1d7dff2cdf07.tar.xz
packages-7f269e026da39a78af5158cc0fba1d7dff2cdf07.zip
user/perl-html-formattext-withlinks: new package
Diffstat (limited to 'user/perl-html-formattext-withlinks')
-rw-r--r--user/perl-html-formattext-withlinks/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/user/perl-html-formattext-withlinks/APKBUILD b/user/perl-html-formattext-withlinks/APKBUILD
new file mode 100644
index 000000000..472ccad5b
--- /dev/null
+++ b/user/perl-html-formattext-withlinks/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
+pkgname=perl-html-formattext-withlinks
+_pkgname=HTML-FormatText-WithLinks
+pkgver=0.15
+pkgrel=0
+pkgdesc="Perl-based HTML-to-text converter with links as footnotes"
+url="https://metacpan.org/release/HTML-FormatText-WithLinks"
+arch="noarch"
+license="Artistic-1.0-Perl OR GPL-2.0-only"
+depends="perl-html-formatter perl-html-tree perl-uri"
+makedepends="perl-dev"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/S/ST/STRUAN/HTML-FormatText-WithLinks-$pkgver.tar.gz"
+builddir="$srcdir/HTML-FormatText-WithLinks-$pkgver"
+
+build() {
+ cd "$builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="cdec4ba94c3f9dfd4e9c8b03be0e24068b23b634499bce062e0b281b26ad3a0288c0d4cc35b4db62fd81ad5f0a0f9ce42a59478af10a81ca2f5901ab79cdf550 HTML-FormatText-WithLinks-0.15.tar.gz"