summaryrefslogtreecommitdiff
path: root/user/perl-inline/APKBUILD
diff options
context:
space:
mode:
authorKiyoshi Aman <kiyoshi.aman+adelie@gmail.com>2019-10-17 18:44:40 -0400
committerKiyoshi Aman <kiyoshi.aman+adelie@gmail.com>2019-10-17 18:44:40 -0400
commitb163eb1b88e25226d5a45816367522bffac0a978 (patch)
tree7cc5851d783856d9199aa6b90d51790b7af38de8 /user/perl-inline/APKBUILD
parent8afb6ffbf97bc59a6b97d110bf88c9357be5ad83 (diff)
downloadpackages-b163eb1b88e25226d5a45816367522bffac0a978.tar.gz
packages-b163eb1b88e25226d5a45816367522bffac0a978.tar.bz2
packages-b163eb1b88e25226d5a45816367522bffac0a978.tar.xz
packages-b163eb1b88e25226d5a45816367522bffac0a978.zip
user/perl-*: modernise
Diffstat (limited to 'user/perl-inline/APKBUILD')
-rw-r--r--user/perl-inline/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/user/perl-inline/APKBUILD b/user/perl-inline/APKBUILD
index 43cb6de1f..35da3125f 100644
--- a/user/perl-inline/APKBUILD
+++ b/user/perl-inline/APKBUILD
@@ -1,6 +1,10 @@
# Contributor: Dan Theisen <djt@hxx.in>
# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
pkgname=perl-inline
+_pkgreal=Inline
+_author=TINITA
+_au=${_author%%"${_author#??}"}
+_a=${_author%%"${_author#?}"}
pkgver=0.83
pkgrel=0
pkgdesc="Write Perl Subroutines in Other Programming Languages"
@@ -11,8 +15,8 @@ depends="perl"
makedepends="perl-dev"
checkdepends="perl-test-warn"
subpackages="$pkgname-doc"
-source="https://cpan.metacpan.org/authors/id/T/TI/TINITA/Inline-$pkgver.tar.gz"
-builddir="$srcdir/Inline-$pkgver"
+source="https://cpan.metacpan.org/authors/id/$_a/$_au/$_author/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
build() {
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor