summaryrefslogtreecommitdiff
path: root/user/perl-test-command
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-02-28 14:58:45 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-02-28 14:58:45 -0600
commit2016f37e2b26264d2fc13bea2c2a8d0dfc0c53ae (patch)
tree9e4643e9ce17db750a35cb00dbd8c274d8ce2c78 /user/perl-test-command
parenta8255bed422a998fc0b918591026b3d7cb584b76 (diff)
downloadpackages-2016f37e2b26264d2fc13bea2c2a8d0dfc0c53ae.tar.gz
packages-2016f37e2b26264d2fc13bea2c2a8d0dfc0c53ae.tar.bz2
packages-2016f37e2b26264d2fc13bea2c2a8d0dfc0c53ae.tar.xz
packages-2016f37e2b26264d2fc13bea2c2a8d0dfc0c53ae.zip
user/perl-test-command: new aport
Diffstat (limited to 'user/perl-test-command')
-rw-r--r--user/perl-test-command/APKBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/user/perl-test-command/APKBUILD b/user/perl-test-command/APKBUILD
new file mode 100644
index 000000000..e70865521
--- /dev/null
+++ b/user/perl-test-command/APKBUILD
@@ -0,0 +1,50 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: Kiyoshi Aman <aerdan@adelielinux.org>
+pkgname=perl-test-command
+_pkgreal=Test-Command
+pkgver=0.11
+pkgrel=1
+pkgdesc="Perl module for Test-Command"
+url="http://search.cpan.org/dist/Test-Command/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends=""
+cpanmakedepends="perl-module-build"
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/D/DA/DANBOO/$_pkgreal-$pkgver.tar.gz"
+
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$builddir"
+ if [ -e Build.PL ]; then
+ perl Build.PL installdirs=vendor
+ else
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ fi
+}
+
+build() {
+ cd "$builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ ./Build
+}
+
+check() {
+ cd "$builddir"
+ ./Build test
+}
+
+package() {
+ cd "$builddir"
+ ./Build install destdir="$pkgdir"
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="9ab83c4695961dbe92cd86efe08f0634 Test-Command-0.11.tar.gz"
+sha256sums="28a3fc6fea73a19f563f11bd0f28186756d4c74207be6deacaad26d2081b9533 Test-Command-0.11.tar.gz"
+sha512sums="79a8f41132b965ad4f6e8b4d97f8fb6181a1e394bcf8825abda2c8ee12dd5f6ef8d7c69df84d306c3841bb516213742c4a0a43c2f3d6b39ce6e163d6d77f45f8 Test-Command-0.11.tar.gz"