summaryrefslogtreecommitdiff
path: root/user/perl-test-runvalgrind
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-10-02 22:44:23 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-10-02 22:44:23 +0000
commit70252859ab7c08136d5086e4d0a67c49928ac352 (patch)
tree31289d0656f94d9e680cb824ef9d3dd4682b81fa /user/perl-test-runvalgrind
parent0948d1de3a33bdd7574b1c76f615997cecc45189 (diff)
downloadpackages-70252859ab7c08136d5086e4d0a67c49928ac352.tar.gz
packages-70252859ab7c08136d5086e4d0a67c49928ac352.tar.bz2
packages-70252859ab7c08136d5086e4d0a67c49928ac352.tar.xz
packages-70252859ab7c08136d5086e4d0a67c49928ac352.zip
user/perl-test-runvalgrind: make more portable
Diffstat (limited to 'user/perl-test-runvalgrind')
-rw-r--r--user/perl-test-runvalgrind/APKBUILD7
-rw-r--r--user/perl-test-runvalgrind/portable-memory-assumptions.patch14
2 files changed, 19 insertions, 2 deletions
diff --git a/user/perl-test-runvalgrind/APKBUILD b/user/perl-test-runvalgrind/APKBUILD
index b882430bc..c6f31b336 100644
--- a/user/perl-test-runvalgrind/APKBUILD
+++ b/user/perl-test-runvalgrind/APKBUILD
@@ -10,7 +10,9 @@ license="MIT"
depends="perl-path-tiny perl-test-trap"
makedepends="perl-dev perl-module-build"
subpackages="$pkgname-doc"
-source="https://cpan.metacpan.org/authors/id/S/SH/SHLOMIF/Test-RunValgrind-$pkgver.tar.gz"
+source="https://cpan.metacpan.org/authors/id/S/SH/SHLOMIF/Test-RunValgrind-$pkgver.tar.gz
+ portable-memory-assumptions.patch
+ "
builddir="$srcdir/Test-RunValgrind-$pkgver"
build() {
@@ -30,4 +32,5 @@ package() {
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="e85547d24fb7c8b0a8fd1a84826eec51d3c4c94d83cbb525517515ecc27b0ba530378a10f8a2ffee9fb1f48eb2e65a6a2654738ee069bd85adcec7f4c205f143 Test-RunValgrind-0.2.0.tar.gz"
+sha512sums="e85547d24fb7c8b0a8fd1a84826eec51d3c4c94d83cbb525517515ecc27b0ba530378a10f8a2ffee9fb1f48eb2e65a6a2654738ee069bd85adcec7f4c205f143 Test-RunValgrind-0.2.0.tar.gz
+f2ebba2310df820666728e5f59c44f5b63cd03efdb42092f22700da13b4f099ae5c911292fb2a0f271f7629343727ea14c5953d2918c98419a580e5a998cb650 portable-memory-assumptions.patch"
diff --git a/user/perl-test-runvalgrind/portable-memory-assumptions.patch b/user/perl-test-runvalgrind/portable-memory-assumptions.patch
new file mode 100644
index 000000000..927da1194
--- /dev/null
+++ b/user/perl-test-runvalgrind/portable-memory-assumptions.patch
@@ -0,0 +1,14 @@
+Upstream: https://github.com/shlomif/perl-Test-RunValgrind/issues/5
+
+--- Test-RunValgrind-0.2.0/lib/Test/RunValgrind.pm.old 2018-01-26 18:07:19.000000000 +0000
++++ Test-RunValgrind-0.2.0/lib/Test/RunValgrind.pm 2018-10-02 22:42:05.450000000 +0000
+@@ -80,7 +80,8 @@
+ index( $$out_text, q{ERROR SUMMARY: 0 errors from 0 contexts} ) >= 0
+ )
+ && ( $self->_ignore_leaks
+- || ( index( $$out_text, q{in use at exit: 0 bytes} ) >= 0 ) )
++ || ( index( $$out_text, q{in use at exit: 0 bytes} ) >= 0 )
++ || ( index( $$out_text, q{still reachable: 0 bytes} ) >= 0 ) )
+ );
+ }
+