summaryrefslogtreecommitdiff
path: root/user/perl-test-runvalgrind
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-10-02 19:28:57 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-10-02 19:28:57 +0000
commit8777ed2584925647d8b6ad7c5fcf06c375a1fdc0 (patch)
treecafd8b98144ebc817534f6cbb47d61fb3346277d /user/perl-test-runvalgrind
parentec2651fdd78a59a55639e7a19289ec91c367addf (diff)
downloadpackages-8777ed2584925647d8b6ad7c5fcf06c375a1fdc0.tar.gz
packages-8777ed2584925647d8b6ad7c5fcf06c375a1fdc0.tar.bz2
packages-8777ed2584925647d8b6ad7c5fcf06c375a1fdc0.tar.xz
packages-8777ed2584925647d8b6ad7c5fcf06c375a1fdc0.zip
user/perl-test-runvalgrind: new package
Diffstat (limited to 'user/perl-test-runvalgrind')
-rw-r--r--user/perl-test-runvalgrind/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/user/perl-test-runvalgrind/APKBUILD b/user/perl-test-runvalgrind/APKBUILD
new file mode 100644
index 000000000..b882430bc
--- /dev/null
+++ b/user/perl-test-runvalgrind/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
+pkgname=perl-test-runvalgrind
+pkgver=0.2.0
+pkgrel=0
+pkgdesc="Tests an external program is 'valgrind clean' from Perl"
+url="https://metacpan.org/release/Test-RunValgrind"
+arch="noarch"
+license="MIT"
+depends="perl-path-tiny perl-test-trap"
+makedepends="perl-dev perl-module-build"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/S/SH/SHLOMIF/Test-RunValgrind-$pkgver.tar.gz"
+builddir="$srcdir/Test-RunValgrind-$pkgver"
+
+build() {
+ cd "$builddir"
+ perl Build.PL installdirs=vendor
+ ./Build
+}
+
+check() {
+ cd "$builddir"
+ ./Build test
+}
+
+package() {
+ cd "$builddir"
+ ./Build install destdir="$pkgdir"
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="e85547d24fb7c8b0a8fd1a84826eec51d3c4c94d83cbb525517515ecc27b0ba530378a10f8a2ffee9fb1f48eb2e65a6a2654738ee069bd85adcec7f4c205f143 Test-RunValgrind-0.2.0.tar.gz"