summaryrefslogtreecommitdiff
path: root/user/perl-test2-plugin-nowarnings
diff options
context:
space:
mode:
authorSíle Ekaterin Liszka <sheila@vulpine.house>2022-05-12 16:30:33 +0000
committerZach van Rijn <me@zv.io>2022-10-21 18:33:59 -0500
commit4563f6efe0b175bd1c7f4ba8a0c9a770e6869bf1 (patch)
treee5294bb1035a9c7c9964518d5eb33bc7bc0df622 /user/perl-test2-plugin-nowarnings
parente695922c1d4016cffa6d07cdf13d3b1ad0211b71 (diff)
downloadpackages-4563f6efe0b175bd1c7f4ba8a0c9a770e6869bf1.tar.gz
packages-4563f6efe0b175bd1c7f4ba8a0c9a770e6869bf1.tar.bz2
packages-4563f6efe0b175bd1c7f4ba8a0c9a770e6869bf1.tar.xz
packages-4563f6efe0b175bd1c7f4ba8a0c9a770e6869bf1.zip
user/perl-test2-plugin-nowarnings: new package
Diffstat (limited to 'user/perl-test2-plugin-nowarnings')
-rw-r--r--user/perl-test2-plugin-nowarnings/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/user/perl-test2-plugin-nowarnings/APKBUILD b/user/perl-test2-plugin-nowarnings/APKBUILD
new file mode 100644
index 000000000..a2f6d7726
--- /dev/null
+++ b/user/perl-test2-plugin-nowarnings/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Síle Ekaterin Liszka <sheila@vulpine.house>
+# Maintainer: Síle Ekaterin Liszka <sheila@vulpine.house>
+pkgname=perl-test2-plugin-nowarnings
+_pkgreal=Test2-Plugin-NoWarnings
+_author=DROLSKY
+_au=${_author%%"${_author#??}"}
+_a=${_author%%"${_author#?}"}
+pkgver=0.09
+pkgrel=0
+pkgdesc="Plugin for ensuring that tests fail if they produce a warning"
+url="https://metacpan.org/pod/Test2::Plugin::NoWarnings"
+arch="all"
+license="Artistic-2.0"
+depends="perl perl-test2-suite"
+checkdepends="perl-ipc-run3"
+makedepends=""
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/$_a/$_au/$_author/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ make test
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="3b93d6c4522e913c4bc9d589b650f784327bed1a36a0dc18943dd2ea34654215333753cb532d5ffff6f0ef0af9ce0859e9744637cff89a1a1a5b936149f9b455 Test2-Plugin-NoWarnings-0.09.tar.gz"