summaryrefslogtreecommitdiff
path: root/user/perl-yaml-libyaml
diff options
context:
space:
mode:
authorDan Theisen <djt@hxx.in>2018-09-26 01:12:11 -0700
committerDan Theisen <djt@hxx.in>2018-09-26 01:12:11 -0700
commit989e88830a86ed99cd893445834ab3fe3ae2ca92 (patch)
tree958411758a919be535085361c61cf5f7fc60c2b5 /user/perl-yaml-libyaml
parent37206f14e542ab14fd94ec401884e89722cc7ae4 (diff)
downloadpackages-989e88830a86ed99cd893445834ab3fe3ae2ca92.tar.gz
packages-989e88830a86ed99cd893445834ab3fe3ae2ca92.tar.bz2
packages-989e88830a86ed99cd893445834ab3fe3ae2ca92.tar.xz
packages-989e88830a86ed99cd893445834ab3fe3ae2ca92.zip
user/perl-yaml-libyaml: new package
Diffstat (limited to 'user/perl-yaml-libyaml')
-rw-r--r--user/perl-yaml-libyaml/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/user/perl-yaml-libyaml/APKBUILD b/user/perl-yaml-libyaml/APKBUILD
new file mode 100644
index 000000000..516971ac2
--- /dev/null
+++ b/user/perl-yaml-libyaml/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Dan Theisen <djt@hxx.in>
+# Maintainer: Adélie Perl Team <adelie-perl@lists.adelielinux.org>
+pkgname=perl-yaml-libyaml
+pkgver=0.74
+pkgrel=0
+pkgdesc="Perl YAML Serialization using XS and libyaml"
+url="https://metacpan.org/pod/YAML::LibYAML"
+arch="all"
+license="Artistic-1.0-Perl AND GPL-2.0"
+depends="perl"
+depends_dev=""
+makedepends="$depends_dev perl-dev"
+install=""
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/I/IN/INGY/YAML-LibYAML-$pkgver.tar.gz"
+builddir="$srcdir/YAML-LibYAML-$pkgver"
+
+build() {
+ cd "$builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="fbc502b1c9173ec76a01e99d303bffd4c97d0a8f30dc6fe8f1962f8edc0296d81fb06c1ef958a0ec81a45259f1f9f6fcdfc3a056054dbf24ae8ce4a4be736614 YAML-LibYAML-0.74.tar.gz"